diff mbox series

[bug#69552,vREVISION,2/2] gnu: Add cyclone.

Message ID f236c0d637192da0d91a04886a5964f0f21f79d7.1709769419.git.takev@disroot.org
State New
Headers show
Series [bug#69552,vREVISION,1/2] gnu: Add cyclone-bootstrap. | expand

Commit Message

TakeV March 6, 2024, 11:56 p.m. UTC
* gnu/packages/scheme.scm (cyclone): New variable.

Change-Id: Icf3890ded917b728177c2831231e87b52d996532
---
 gnu/packages/scheme.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index e0151e954c..29b8623310 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1317,3 +1317,30 @@  (define cyclone-bootstrap
 installed.")
     (license expat)))
 
+(define-public cyclone
+  (package
+    ;; the bootstrap compiler and final compiler share most build reqs
+    (inherit cyclone-bootstrap)
+    (name "cyclone")
+    (version "0.36.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/justinethier/cyclone.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0qz5sdcnqkvw78gx86k3g1f0di5aqagdxqvzc35j50h1q5kj67z6"))))
+    (native-inputs (list cyclone-bootstrap))
+    (home-page "http://justinethier.github.io/cyclone/")
+    (synopsis "Fast R7RS Scheme-to-C compiler")
+    (description
+     "Cyclone Scheme is a brand-new compiler that allows real-world application
+development using the R7RS Scheme Language standard.
+
+Cyclone's runtime uses Cheney on the MTA to implement full tail recursion,
+continuations, multiple native threads, and generational garbage collection.
+The on-the-fly garbage collector manages the second-generation heap and 
+performs major collections without 'stopping the world'.")
+    (license expat)))