diff mbox series

[bug#63341,v2] gnu: Use dummy linker for '*-elf' systems.

Message ID f1c6f99e5a6a4c5b5d17cc6faf719251e53b73e9.1684145713.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#63341,v2] gnu: Use dummy linker for '*-elf' systems. | expand

Commit Message

dziltener--- via Guix-patches via May 15, 2023, 10:16 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Return "no-ld.so" for
systems with a "-elf" suffix.
---
 gnu/packages/bootstrap.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)


base-commit: 79e9a70c94728272386c7e023a93aa33ebd27d34

Comments

Efraim Flashner May 15, 2023, 11:55 a.m. UTC | #1
Looks good to me!

On Mon, May 15, 2023 at 06:16:00PM +0800, iyzsong@envs.net wrote:
> From: 宋文武 <iyzsong@member.fsf.org>
> 
> * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Return "no-ld.so" for
> systems with a "-elf" suffix.
> ---
>  gnu/packages/bootstrap.scm | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
> index 9a46f97c81..5f6a3acc83 100644
> --- a/gnu/packages/bootstrap.scm
> +++ b/gnu/packages/bootstrap.scm
> @@ -325,14 +325,11 @@ (define* (glibc-dynamic-linker
>  
>       ;; XXX: This one is used bare-bones, without a libc, so add a case
>       ;; here just so we can keep going.
> -     ((string=? system "arm-elf") "no-ld.so")
>       ((string=? system "arm-eabi") "no-ld.so")
> -     ((string=? system "xtensa-elf") "no-ld.so")
>       ((string=? system "avr") "no-ld.so")
> -     ((string=? system "propeller-elf") "no-ld.so")
>       ((string=? system "i686-mingw") "no-ld.so")
>       ((string=? system "x86_64-mingw") "no-ld.so")
> -     ((string=? system "vc4-elf") "no-ld.so")
> +     ((string-suffix? "-elf" system) "no-ld.so")
>  
>       (else (error "dynamic linker name not known for this system"
>                    system)))))
> 
> base-commit: 79e9a70c94728272386c7e023a93aa33ebd27d34
> -- 
> 2.40.1
>
宋文武 May 15, 2023, 1:33 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> Looks good to me!

Pushed, thank you for review!
diff mbox series

Patch

diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 9a46f97c81..5f6a3acc83 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -325,14 +325,11 @@  (define* (glibc-dynamic-linker
 
      ;; XXX: This one is used bare-bones, without a libc, so add a case
      ;; here just so we can keep going.
-     ((string=? system "arm-elf") "no-ld.so")
      ((string=? system "arm-eabi") "no-ld.so")
-     ((string=? system "xtensa-elf") "no-ld.so")
      ((string=? system "avr") "no-ld.so")
-     ((string=? system "propeller-elf") "no-ld.so")
      ((string=? system "i686-mingw") "no-ld.so")
      ((string=? system "x86_64-mingw") "no-ld.so")
-     ((string=? system "vc4-elf") "no-ld.so")
+     ((string-suffix? "-elf" system) "no-ld.so")
 
      (else (error "dynamic linker name not known for this system"
                   system)))))