diff mbox series

[bug#43309] Add Hexyl into the package list

Message ID f198e564-d321-7628-9c2e-919fa2ac6e1d@gmail.com
State Accepted
Headers show
Series [bug#43309] Add Hexyl into the package list | expand

Commit Message

Gabriel Arazas Sept. 10, 2020, 1:16 p.m. UTC
Hello! I've finally getting serious into Guix and wanting to start 
contributing to it immediately to help expand the package list.

I've followed the video tutorials from the official website and some 
referencing to the manual and I got my first package. I have to say it's 
quite straightforward coming from someone with no experience in software 
packaging.

Anyways, attached to my email is my patch adding Hexyl 
(https://github.com/sharkdp/hexyl) into the list.

I'll be looking forward to add more packages. :)


Best regards,

Gabriel Arazas

Comments

Efraim Flashner Sept. 11, 2020, 11:26 a.m. UTC | #1
Looks great! I tweaked the description slightly and pushed it. Thanks!
Efraim Flashner Sept. 11, 2020, 11:27 a.m. UTC | #2
... and I forgot to close the bug
diff mbox series

Patch

From 264a03e5c18d8ff852478ed8abee2a1c627c8955 Mon Sep 17 00:00:00 2001
From: Gabriel Arazas <foo.dogsquared@gmail.com>
Date: Thu, 10 Sep 2020 19:27:31 +0800
Subject: [PATCH] gnu: Add hexyl.

* gnu/packages/rust-apps.scm (hexyl): New variable.
---
 gnu/packages/rust-apps.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 76be9acad1..d9ff303e0c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -205,6 +206,34 @@  While it does not seek to mirror all of find's powerful functionality, it
 provides defaults for 80% of the use cases.")
     (license (list license:expat license:asl2.0))))
 
+(define-public hexyl
+  (package
+    (name "hexyl")
+    (version "0.8.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "hexyl" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0sipag77196467idbznbk5q5lwhqz85zw7y1pwg9b27jxqyk04rp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ansi-term" ,rust-ansi-term-0.12)
+        ("rust-atty" ,rust-atty-0.2)
+        ("rust-clap" ,rust-clap-2)
+        ("rust-libc" ,rust-libc-0.2))))
+    (home-page "https://github.com/sharkdp/hexyl")
+    (synopsis "Command-line hex viewer")
+    (description
+      "This package provides a command line hex viewer.
+It uses a colored output for distinguishing different kinds of bytes such as
+NULL bytes, ASCII whitespace, and non-ASCII whitespace.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public ripgrep
   (package
     (name "ripgrep")
-- 
2.28.0