diff mbox series

[bug#67950,2/3] gnu: Add informlib.

Message ID f18cc2ce-f78d-ff72-eeea-dfb997d41b2f@disroot.org
State New
Headers show
Series gnu: Add devours. | expand

Commit Message

Adam Faiz Dec. 21, 2023, 10:42 a.m. UTC
From 55f87c2ef4fe17845ac94e9e0ef5ccae98b1777f Mon Sep 17 00:00:00 2001
Message-ID: <55f87c2ef4fe17845ac94e9e0ef5ccae98b1777f.1703154486.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1703154486.git.adam.faiz@disroot.org>
References: <cover.1703154486.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 21 Dec 2023 18:17:29 +0800
Subject: [PATCH 2/3] gnu: Add informlib.

* gnu/packages/game-development.scm (informlib): New variable.
---
 gnu/packages/game-development.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0c467de23f..6e080b3f36 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages game-development)
   #:use-module (guix svn-download)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
@@ -2796,6 +2797,30 @@  (define-public inform
     (home-page "https://jxself.org/git/inform.git")
     (license license:gpl3+)))
 
+(define-public informlib
+  (package
+    (name "informlib")
+    (version "6.12.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://jxself.org/git/informlib.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fcnw4jjzln402qk097n2s8y24vw1p3mmlmh6k1mbr2zfajjcn5r"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan
+      #~'(("." "lib"))))
+    (synopsis "Inform 6 standard library")
+    (description
+     "This package provides the standard library for Inform 6.")
+    (home-page "https://jxself.org/git/informlib.git")
+    (license license:agpl3+)))
+
 (define-public instead
   (package
     (name "instead")