diff mbox series

[bug#69763] gnu: python-build: Update python-pypa-build to 1.1.1.

Message ID f146b863de9ccff6624ca2eedb639c23@lyrion.ch
State New
Headers show
Series [bug#69763] gnu: python-build: Update python-pypa-build to 1.1.1. | expand

Commit Message

Daniel Ziltener March 12, 2024, 11:40 p.m. UTC
---
 gnu/packages/python-build.scm | 23 ++++++++---------------
 1 file changed, 8 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 2ea457cdba..a381f6fcd0 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -464,27 +464,21 @@  (define-public python-packaging-bootstrap
 (define-public python-pypa-build
   (package
     (name "python-pypa-build")
-    (version "0.7.0")
+    (version "1.1.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "build" version))
               (sha256
                (base32
-                "17xqija27x4my1yrnk6q2vwln60r39g2dhby9zg2l99qjgbdrahs"))))
-    (build-system python-build-system)
+                "0c9a7nalcyryxp85nf8sj2bpvnd6sgdchb5s6kkw5ami8nxnbslf"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f                      ;to tests in the PyPI release
-       #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'use-toml-instead-of-tomli
-                    ;; Using toml instead of tomli eases bootstrapping.
-                    (lambda _
-                      (substitute* "setup.cfg"
-                        (("tomli>=.*")
-                         "toml\n")))))))
+     `(#:tests? #f))                    ;to tests in the PyPI release
+    (native-inputs
+     (list python-flit-core))
     (propagated-inputs
-     `(("python-packaging" ,python-packaging-bootstrap)
-       ("python-pep517", python-pep517-bootstrap)
-       ("python-toml" ,python-toml)))
+     `(("python-pyproject-hooks" ,python-pyproject-hooks)
+       ("python-packaging" ,python-packaging-bootstrap)))
     (home-page "https://pypa-build.readthedocs.io/en/latest/")
     (synopsis "Simple Python PEP 517 package builder")
     (description "The @command{build} command invokes the PEP 517 hooks to
@@ -762,4 +756,3 @@  (define-public python-pdm-backend
      "PDM-Backend is a build backend that supports the latest packaging
 standards, which includes PEP 517, PEP 621 and PEP 660.")
     (license license:expat)))
-