diff mbox series

[bug#39931] gnu: Added emacs-org-journal

Message ID f0faad1c-7fdb-7e62-f2ac-d47db70a901d@riseup.net
State Accepted
Headers show
Series [bug#39931] gnu: Added emacs-org-journal | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Martin Becze March 7, 2020, 6:23 p.m. UTC
opps i messed that the last patch file. Here is the correct one!

On 3/6/20 11:05 AM, Martin Becze wrote:
> Thanks for the review Nicolas!
> 
> Attached is an updated patch.
> 
> On 3/5/20 3:18 PM, Nicolas Goaziou wrote:
>> Hello,
>>
>> Martin Becze <mjbecze@riseup.net> writes:
>>
>>> * gnu/packages/emacs-xyz.scm (emacs-org-journal): New Variable.
>>
>> Thank you!
>>
>>> +(define-public emacs-org-journal
>>> +  (package
>>> +    (name "emacs-org-journal")
>>> +    (version "2.0.0")
>>> +    (home-page "https://github.com/bastibe/org-journal")
>>
>> Usually, `home-page' is lower in the package definition, right above 
>> `synopsis'.
>>
>>> +    (source
>>> +     (origin
>>> +       (method git-fetch)
>>> +       (uri (git-reference
>>> +             (url home-page)
>>
>> It may be just me, but I'm not a big fan of this trick, because it binds
>> two information that might be unrelated at some point. I suggest to use
>> the full URL instead.
>>
>> OTOH, the above is not a strong argument either, so it's up to you.
>>
>>> +             (commit version)))
>>> +       (file-name (git-file-name name version))
>>> +       (sha256
>>> +        (base32
>>> +         "18dqd0jy2x530lk0h4fcn9cld9qh4w7b3vxa60fpiia628vsv1dg"))))
>>> +    (build-system emacs-build-system)
>>> +    (synopsis "A simple org-mode based journaling mode")
>>
>> I suggest "Simple Org mode based journaling mode". In any case, I think
>> "guix lint" complains when a synopsis starts with an article.
>>
>>> +    (description "@code{org-journal} maintains a set of files, 
>>> depending on the value
>>> + of @{org-journal-file-type}, a file represents a day, week, month 
>>> or year. When
>>> +@code{org-journal-file-type} is set to =’daily=, each file represent 
>>> a day. In case
>>> +@{org-journal-file-type} is set to =’weekly=, a file represents
>>> a week, etc.
>>
>> "Org Journal maintains a set of files, which may represent a day,
>> a week, a month or a year."
>>
>> IOW, I think description should not leak the innards of the package.
>>
>>> + Convenient bindings allow the creation of journal records in the 
>>> current daily,
>>> + weekly, monthly or yearly file and search within all records or 
>>> specified time
>>> + intervals. All records can be browsed and searched from the Emacs 
>>> Calendar for
>>> + convenience.")
>>
>> You need to add two spaces after full stops.
>>
>> Could you send an updated patch?
>>
>> Regards,
>>

Comments

Nicolas Goaziou March 8, 2020, 10:24 a.m. UTC | #1
Hello,

Martin Becze <mjbecze@riseup.net> writes:

> opps i messed that the last patch file. Here is the correct one!

Thank you!

I slightly reworded the beginning of the description so it now starts
with a full sentence. Applied as
1eb3b2b666fd6ae5c0e3b09aa08c97b9d23e26be.

Regards,
diff mbox series

Patch

From b9f584ae41d70209feb230d281df420e0e30c239 Mon Sep 17 00:00:00 2001
From: Martin Becze <mjbecze@riseup.net>
Date: Thu, 5 Mar 2020 12:40:42 -0500
Subject: [PATCH v3] gnu: Added emacs-org-journal

* gnu/packages/emacs-xyz.scm (emacs-org-journal): New Variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 19c4ed7571..2cc7d3a485 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -60,6 +60,7 @@ 
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
 ;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21732,3 +21733,29 @@  supports generation of phonetic and numeric passwords.")
 Separated Value) files.  It follows the format as defined in RFC 4180 \"Common
 Format and MIME Type for CSV Files\" (@url{http://tools.ietf.org/html/rfc4180}).")
     (license license:gpl3+)))
+
+(define-public emacs-org-journal
+  (package
+    (name "emacs-org-journal")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/bastibe/org-journal.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "18dqd0jy2x530lk0h4fcn9cld9qh4w7b3vxa60fpiia628vsv1dg"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bastibe/org-journal")
+    (synopsis "Simple org-mode journaling mode")
+    (description "Adapted from @url{https://www.emacswiki.org/emacs/PersonalDiary}
+Functions to maintain a simple personal diary / journal using in Emacs.  
+Convenient bindings allow the creation of journal records in the current daily,
+weekly, monthly or yearly file and search within all records or specified time
+intervals.  All records can be browsed and searched from the Emacs Calendar for
+convenience.  All entries in a specified TODO state will be carried over to the
+next day.")
+    (license license:bsd-3)))
-- 
2.25.1