diff mbox series

[bug#71897,v10,4/9] gnu: Add cppgir-for-telegram-desktop.

Message ID f0e52619ace1d36c9832ae4cf2a3183a12037afd.1727046228.git.i@dan.games
State New
Headers show
Series [bug#71897,v10,1/9] gnu: xdg-desktop-portal: Update to 1.18.4. | expand

Commit Message

dan Sept. 22, 2024, 11:04 p.m. UTC
* gnu/packages/glib.scm (cppgir-for-telegram-desktop): New variable.

Change-Id: Ib9ca3bd376f32d13939adabd2c52e1eb24e2ddcb
---
 gnu/packages/glib.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a479199cdd..a15a7ce58a 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1621,3 +1621,22 @@  (define-public cppgir
 introspection annotations into a set of C++ files defining suitable
 namespaces, classes and other types that together form a C++ binding.")
     (license license:expat)))
+
+;; telegram-desktop requires a more recent version of cppgir
+(define-public cppgir-for-telegram-desktop
+  (let ((commit "9c4f5820d94d62ab451501f016bfea97156518f4")
+        (revision "0"))
+    (package
+      (inherit cppgir)
+      (name "cppgir-for-telegram-desktop")
+      (version (git-version "2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://gitlab.com/mnauw/cppgir")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fa9nf4yljfarihaqj5kd98yysrky7q316mh6l5b1rq39ga15k9b")))))))