diff mbox series

[bug#66899,2/2] gnu: Add r-matrixtests.

Message ID f0d912d69600501fce0c8e4cc2bac323889e39a0.1698945230.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#66899,1/2] gnu: Add r-nestedcv. | expand

Commit Message

nafkhamdc Nov. 2, 2023, 5:13 p.m. UTC
* gnu/packages/cran.scm (r-matrixtests): New variable.

Change-Id: I62f7bd760fc8603425906c304ef4293da1c0cf61
---
 gnu/packages/cran.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5aff1a2dd5..6ff4c9324a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3125,6 +3125,27 @@  (define-public r-grr
 functions are simplified but can be faster or have other advantages.")
     (license license:gpl3)))
 
+(define-public r-matrixtests
+  (package
+    (name "r-matrixtests")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "matrixTests" version))
+       (sha256
+        (base32 "0d7i00cxzszfdnjm8q5b72ildic8nig6fbw7rba6acdnllpp7sza"))))
+    (properties `((upstream-name . "matrixTests")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-matrixstats))
+    (home-page "https://github.com/karoliskoncevicius/matrixTests")
+    (synopsis "Statistical hypothesis tests on rows and columns of matrices")
+    (description
+     "This package offers quick statistical hypothesis testing for matrix rows/columns.
+The main goals are speed through vectorization, detailed and user-friendly
+output, and compatibility with tests implemented in R.")
+    (license license:gpl2)))
+
 (define-public r-matrix-utils
   (package
     (name "r-matrix-utils")