diff mbox series

[bug#63091,v3,1/2] gnu: sssd: Fix failing tests by using samba/pinned input

Message ID f0c1971bc8a482b2e0d5e487d522d2231011823d.1683162845.git.bjc@spork.org
State New
Headers show
Series [bug#63091,v3,1/2] gnu: sssd: Fix failing tests by using samba/pinned input | expand

Commit Message

Brian Cully May 4, 2023, 1:14 a.m. UTC
The latest samba package (4.18.1) causes a SIGABRT in ad_common_tests and
ad_gpo_tests. The pinned version (4.17.0) allows them to succeed, so use that
instead.

* gnu/packages/sssd.scm (sssd) [inputs]: Change samba to samba/pinned.
---
 gnu/packages/sssd.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 91bfd30ee3f35dfb7048bf42aea92f939cffbf17
prerequisite-patch-id: 5908eef27f1e709c3d066ab89eb094458c0109ac

Comments

Ludovic Courtès May 19, 2023, 2:14 p.m. UTC | #1
Brian Cully <bjc@spork.org> skribis:

> The latest samba package (4.18.1) causes a SIGABRT in ad_common_tests and
> ad_gpo_tests. The pinned version (4.17.0) allows them to succeed, so use that
> instead.
>
> * gnu/packages/sssd.scm (sssd) [inputs]: Change samba to samba/pinned.

[...]

> * gnu/packages/sssd.scm (sssd) [native-inputs]: Add python-toolchain.
> [ensure-no-mtimes-pre-1980]: New phase.

Finally applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index a6b4c8aa90..4e585a62de 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -267,7 +267,7 @@  (define-public sssd
            pcre2
            popt
            python
-           samba
+           samba/pinned
            talloc
            tdb
            tevent))