diff mbox series

[bug#71650] gnu: Add r-cmdstanr.

Message ID f0b4e2889d976e74c3527bc6a4a85d8446027e12.1718808804.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#71650] gnu: Add r-cmdstanr. | expand

Commit Message

Afkhami, Navid June 19, 2024, 2:53 p.m. UTC
* gnu/packages/bioinformatics.scm (r-cmdstanr): New variable.

Change-Id: Ic9e83486f7ab7f0e7075343af630c4dcecf597b5
---
 gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: da1f3aff2ea9a98651ebc69c8385ba136fe2e325
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cdda029809..e2632a5aa4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11534,6 +11534,43 @@  (define-public r-chromunity
 Pore-C concatemers.")
       (license license:gpl3))))
 
+(define-public r-cmdstanr
+  (let ((commit "a45d4f7d686aa6b57ce25f342a71eea79507f01c")
+        (revision "1"))
+    (package
+      (name "r-cmdstanr")
+      (version (git-version "0.8.1.9000" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/stan-dev/cmdstanr")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01vyh3sy704rs7yvaka2hp6vld0mdl7hbrs20dpbwidgm4ksrvsi"))))
+      (properties `((upstream-name . "cmdstanr")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-checkmate
+                               r-data-table
+                               r-jsonlite
+                               r-posterior
+                               r-processx
+                               r-r6
+                               r-rlang
+                               r-withr))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/stan-dev/cmdstanr")
+      (synopsis "R interface to 'CmdStan'")
+      (description
+       "This package provides a lightweight interface to Stan <https://mc-stan.org>.
+The @code{CmdStanR} interface is an alternative to RStan that calls the command
+line interface for compilation and running algorithms instead of interfacing
+with C++ via Rcpp'.  This has many benefits including always being compatible
+with the latest version of Stan, fewer installation errors, fewer unexpected
+crashes in RStudio, and a more permissive license.")
+      (license license:bsd-3))))
+
 (define-public r-dnamcrosshyb
   ;; There aren't any releases.
   (let ((commit "fe8acb33667e81f00dcb84e0fa75c87ab2db5d8f")