diff mbox series

[bug#71001,v2] gnu: libwacom: Update to 2.11.0.

Message ID f060556ac3bb535ceb16b7dc52ce23ea4df62882.1717346460.git.dariqq@posteo.net
State New
Headers show
Series [bug#71001,v2] gnu: libwacom: Update to 2.11.0. | expand

Commit Message

Dariqq June 2, 2024, 4:41 p.m. UTC
With the 2.9 release the license got clarified to be hpnd.

* gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
[native-inputs]: Remove python-evdev.
[inputs]: Add python, python-libevdev, python-pyudev.
[propagated-inputs]: Add libevdev.
[license]: Correct license to hpnd.

Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
---
Changes in v2: Removed the PYTHONPATH wrapper becasue I don't think it is worth the extra 100MB in size and it also captures native python inputs.

 gnu/packages/xdisorg.scm | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)


base-commit: bc06affabcf68bbe93e9afee13bef8cc8c6336a2

Comments

Christopher Baines June 11, 2024, 11:36 a.m. UTC | #1
Dariqq <dariqq@posteo.net> writes:

> With the 2.9 release the license got clarified to be hpnd.
>
> * gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
> [native-inputs]: Remove python-evdev.
> [inputs]: Add python, python-libevdev, python-pyudev.
> [propagated-inputs]: Add libevdev.
> [license]: Correct license to hpnd.
>
> Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
> ---
> Changes in v2: Removed the PYTHONPATH wrapper becasue I don't think it is worth the extra 100MB in size and it also captures native python inputs.
>
>  gnu/packages/xdisorg.scm | 16 ++++++++++------
>  1 file changed, 10 insertions(+), 6 deletions(-)

Looks good to me, I've pushed this to master as
1d5bfe45134259676e609020ac64cbc1a1a81d2b.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 357a868528..ccf28f3990 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1449,7 +1449,7 @@  (define-public xcape
 (define-public libwacom
   (package
     (name "libwacom")
-    (version "2.6.0")
+    (version "2.11.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1457,7 +1457,7 @@  (define-public libwacom
                     "libwacom-" version "/libwacom-" version ".tar.xz"))
               (sha256
                (base32
-                "13x978gzyw28cqd985m5smiqgza0xp3znb1s0msmn8vmjjlwqxi3"))))
+                "0i0k333kfc6ai4vxqijjybj38s9j1hly2x327113lm1cr0g9jgxh"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -1466,15 +1466,19 @@  (define-public libwacom
      (list pkg-config
            ;; For tests.
            python
-           python-evdev
            python-libevdev
            python-pytest
            python-pyudev))
     (inputs
-     (list gtk+ eudev libxml2))
+     (list gtk+
+           eudev
+           libxml2
+           python
+           python-libevdev
+           python-pyudev))
     (propagated-inputs
      ;; libwacom.pc 'Requires' these:
-     (list glib libgudev))
+     (list glib libevdev libgudev))
     (home-page "https://linuxwacom.github.io/")
     (synopsis "Helper library for graphics tablet settings")
     (description
@@ -1482,7 +1486,7 @@  (define-public libwacom
 intended to be used by client-programs that need model identification.  It is
 already being used by the gnome-settings-daemon and the GNOME Control Center
 Wacom tablet applet.")
-    (license license:x11)))
+    (license license:hpnd)))
 
 (define-public xf86-input-wacom
   (package