diff mbox series

[bug#57287] gnu: Add tp-smapi-module.

Message ID f04fac9f43bbb8a7a0d59961d2474c4777fcc8d6.1660855176.git.simon@netpanic.org
State Accepted
Headers show
Series [bug#57287] gnu: Add tp-smapi-module. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Streit Aug. 18, 2022, 8:51 p.m. UTC
From: Simon Streit <simon@netpanic.org>

* gnu/packages/linux.scm (tp-smapi-module): New variable.
---
 gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb8b4fa5a8..b7f09f123b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9410,3 +9410,30 @@  (define-public evtest
 directly from the kernel device and prints a device description and the events
 with the value and the symbolic name.")
     (license license:gpl2+)))
+
+(define-public tp-smapi-module
+  (package
+    (name "tp-smapi-module")
+    (version "0.43")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/linux-thinkpad/tp_smapi")
+                    (commit (string-append "tp-smapi/" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rjb0njckczc2mj05cagvj0lkyvmyk6bw7wkiinv81lw8m90g77g"))))
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f))                    ;there are none.
+    (home-page "https://github.com/linux-thinkpad/tp_smapi")
+    (synopsis
+     "The tp_smapi kernel module exposes some features of ThinkPad hardware")
+    (description
+     "Currently, the main functionality tp_smapi
+implements is control of battery chargin and extended battery status.
+The software package also includes an improved version of the HDAPS
+driver.  The underlying hardware interfaces are SMAPI and direct access
+to the embedded controller.")
+    (license license:gpl2+)))