@@ -9410,3 +9410,30 @@ (define-public evtest
directly from the kernel device and prints a device description and the events
with the value and the symbolic name.")
(license license:gpl2+)))
+
+(define-public tp-smapi-module
+ (package
+ (name "tp-smapi-module")
+ (version "0.43")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linux-thinkpad/tp_smapi")
+ (commit (string-append "tp-smapi/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rjb0njckczc2mj05cagvj0lkyvmyk6bw7wkiinv81lw8m90g77g"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ;there are none.
+ (home-page "https://github.com/linux-thinkpad/tp_smapi")
+ (synopsis
+ "The tp_smapi kernel module exposes some features of ThinkPad hardware")
+ (description
+ "Currently, the main functionality tp_smapi
+implements is control of battery chargin and extended battery status.
+The software package also includes an improved version of the HDAPS
+driver. The underlying hardware interfaces are SMAPI and direct access
+to the embedded controller.")
+ (license license:gpl2+)))
From: Simon Streit <simon@netpanic.org> * gnu/packages/linux.scm (tp-smapi-module): New variable. --- gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++ 1 file changed, 27 insertions(+)