diff mbox series

[bug#67446] gnu: drawpile: Update drawpile to 2.1.20.

Message ID efdade1a42e23124ce1e2d60d8ba8a64@purge.sh
State New
Headers show
Series [bug#67446] gnu: drawpile: Update drawpile to 2.1.20. | expand

Commit Message

spacecadet Nov. 25, 2023, 4:02 p.m. UTC
Update drawpile to 2.1.20 and remove let that was needed for specific
commit after drawpile 2.1.17 to fix building with libmicrohttpd>=0.9.71.
---
  gnu/packages/graphics.scm | 75 +++++++++++++++++++--------------------
  1 file changed, 36 insertions(+), 39 deletions(-)

+    (description "Drawpile is a drawing program that allows share the 
canvas
  with other users in real time.

  Some feature highlights:
@@ -2341,7 +2338,7 @@ (define-public drawpile
  @item Encrypted connections using SSL
  @item Automatic port forwarding with UPnP
  @end itemize\n")
-      (license license:gpl3+))))
+    (license license:gpl3+))))

  (define-public openxr
    (package
+  (package
+    (name "drawpile")
+    (version "2.1.20")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/drawpile/Drawpile")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                
"0r250yv1ks36yxdgn2vjl0h6ai86gg37pz83d5qi6qc1mmlsqc8y"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:configure-flags
+       (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+    (native-inputs
+     (list extra-cmake-modules pkg-config))
+    (inputs
+     (list giflib
+           karchive
+           kdnssd
+           libmicrohttpd
+           libsodium
+           libvpx
+           libxi
+           ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
+           qtbase-5
+           qtkeychain
+           qtmultimedia-5
+           qtsvg-5
+           qtx11extras))
+    (home-page "https://drawpile.net")
+    (synopsis "Collaborative drawing program")
+    (description "Drawpile is a drawing program that allows share the 
canvas
  with other users in real time.

  Some feature highlights:
@@ -2341,7 +2338,7 @@ (define-public drawpile
  @item Encrypted connections using SSL
  @item Automatic port forwarding with UPnP
  @end itemize\n")
-      (license license:gpl3+))))
+    (license license:gpl3+))))

  (define-public openxr
    (package

base-commit: 13bc0633e77c73389e530a4c45e2de5a823f106b
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 00e273b853..c3c58085bf 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2288,44 +2288,41 @@  (define-public superfamiconv
      (license license:expat)))

  (define-public drawpile
-  ;; This commit fix building with libmicrohttpd>=0.71.
-  (let ((commit "ed1a75deb113da2d1df91a28f557509c4897130e")
-        (revision "1"))
-    (package
-      (name "drawpile")
-      (version (string-append "2.1.17-" revision "." (string-take 
commit 9)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/drawpile/Drawpile")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  
"1y21h1hk9ipkjvhjgas0c5hkjyan92vsxbxrn60c906hzqln2fr1"))))
-      (build-system qt-build-system)
-      (arguments
-       '(#:configure-flags
-         (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
-      (native-inputs
-       (list extra-cmake-modules pkg-config))
-      (inputs
-       (list giflib
-             karchive
-             kdnssd
-             libmicrohttpd
-             libsodium
-             libvpx
-             libxi
-             ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
-             qtbase-5
-             qtkeychain
-             qtmultimedia-5
-             qtsvg-5
-             qtx11extras))
-      (home-page "https://drawpile.net")
-      (synopsis "Collaborative drawing program")
-      (description "Drawpile is a drawing program that allows share the 
canvas
+  (package
+    (name "drawpile")
+    (version "2.1.20")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/drawpile/Drawpile")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                
"0r250yv1ks36yxdgn2vjl0h6ai86gg37pz83d5qi6qc1mmlsqc8y"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:configure-flags
+       (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+    (native-inputs
+     (list extra-cmake-modules pkg-config))
+    (inputs
+     (list giflib
+           karchive
+           kdnssd
+           libmicrohttpd
+           libsodium
+           libvpx
+           libxi
+           ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
+           qtbase-5
+           qtkeychain
+           qtmultimedia-5
+           qtsvg-5
+           qtx11extras))
+    (home-page "https://drawpile.net")
+    (synopsis "Collaborative drawing program")