[bug#77268] gnu: mepo: Update to 1.3.4.
Commit Message
* gnu/packages/geo.scm (mepo): Update to 1.3.4.
[arguments]:
<zig>: Specify Zig 0.14.
<phases>: Add 'patch-geoclue-demos-path.
[inputs]: Add geoclue.
Change-Id: Ibb9020dcb8202becced1c70ac2a616502dec466e
---
gnu/packages/geo.scm | 23 +++++++++++++++++------
1 file changed, 17 insertions(+), 6 deletions(-)
base-commit: 4d655e48836d5be89942a38da532431316f6887b
Comments
Am Wed, Mar 26, 2025 at 03:02:56PM +0900 schrieb Nguyễn Gia Phong:
> * gnu/packages/geo.scm (mepo): Update to 1.3.4.
Pushed, thanks!
Andreas
@@ -155,7 +155,8 @@ (define-module (gnu packages geo)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages zig))
(define-public gmt
(package
@@ -618,7 +619,7 @@ (define-public libgeotiff
(define-public mepo
(package
(name "mepo")
- (version "1.3.3")
+ (version "1.3.4")
(source
(origin
(method git-fetch)
@@ -627,15 +628,25 @@ (define-public mepo
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "025nxkilar3gdif2f1zsiy27614x2hbpcmh38sl61ng37aji0jw4"))))
+ (base32 "0cz4ihz4mw1v47x3xycyayfs28xlns2war2dif31awzg02a3rlfl"))))
(build-system zig-build-system)
(arguments
(list #:install-source? #f
- ;; Work around https://github.com/ziglang/zig/issues/17384
- #:zig-build-flags #~(list "--search-prefix" #$curl)
+ #:zig zig-0.14
#:zig-release-type "safe"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-geoclue-demos-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "scripts/mepo_ui_menu_user_pin_updater.sh"
+ (("/usr/libexec/geoclue-2.0/demos/agent")
+ (search-input-file
+ inputs
+ "libexec/geoclue-2.0/demos/agent"))
+ (("/usr/libexec/geoclue-2.0/demos/where-am-i")
+ (search-input-file
+ inputs
+ "libexec/geoclue-2.0/demos/where-am-i")))))
(add-after 'install 'wrap-scripts
(lambda* (#:key inputs #:allow-other-keys)
(let ((bin-dirs
@@ -675,7 +686,7 @@ (define-public mepo
"mepo_ui_menu_user_pin_updater.sh"))))))))
(native-inputs (list pkg-config))
;; TODO: package Mobroute
- (inputs (list bash-minimal busybox curl gpsd jq ncurses
+ (inputs (list bash-minimal busybox curl geoclue gpsd jq ncurses
sdl2 sdl2-gfx sdl2-image sdl2-ttf
util-linux xwininfo zenity))
(home-page "https://mepo.lrdu.org")