diff mbox series

[bug#65901,gnome-team] gnu: vala: Update to 0.56.13.

Message ID efd66c95c37c4a1b2901e70d4684df67e46782c5.1694571493.git.jackhill@jackhill.us
State New
Headers show
Series [bug#65901,gnome-team] gnu: vala: Update to 0.56.13. | expand

Commit Message

Jack Hill Sept. 13, 2023, 2:18 a.m. UTC
* gnu/packages/gnome.scm (vala): Update to 0.56.13.
---

I noticed that Dino was failing to build on the gnome-team branch. It's
apparently because of some unintentional breaking changes in vala
0.56.11 and 0.56.12. This patch updates vala to 0.56.13 which restores
the previous behaviour.

https://github.com/dino/dino/issues/1479
https://gitlab.gnome.org/GNOME/vala/-/issues/1478


 gnu/packages/gnome.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 20e3f3e1151b2f22ae7fb5aa8764148654f35090

Comments

Maxim Cournoyer Sept. 13, 2023, 3:43 p.m. UTC | #1
Hi,

Jack Hill <jackhill@jackhill.us> writes:

> * gnu/packages/gnome.scm (vala): Update to 0.56.13.
> ---
>
> I noticed that Dino was failing to build on the gnome-team branch. It's
> apparently because of some unintentional breaking changes in vala
> 0.56.11 and 0.56.12. This patch updates vala to 0.56.13 which restores
> the previous behaviour.
>
> https://github.com/dino/dino/issues/1479
> https://gitlab.gnome.org/GNOME/vala/-/issues/1478
>
>
>  gnu/packages/gnome.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index ad118090eb..c9a4290472 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -4424,7 +4424,7 @@ (define-public seahorse
>  (define-public vala
>    (package
>      (name "vala")
> -    (version "0.56.12")
> +    (version "0.56.13")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "mirror://gnome/sources/vala/"
> @@ -4432,7 +4432,7 @@ (define-public vala
>                                    "vala-" version ".tar.xz"))
>                (sha256
>                 (base32
> -                "0n9m4l8d2n4wmgn9l5gdhnr6xl5ms7483ng5fxqak8xygi5xbjcj"))))
> +                "01xfarnhpp30wmv9mwayw8751glwppl0sva79j3y9qf76qq25229"))))
>      (build-system glib-or-gtk-build-system)
>      (arguments
>       (list
>
> base-commit: 20e3f3e1151b2f22ae7fb5aa8764148654f35090

LGTM!
Liliana Marie Prikler Sept. 24, 2023, 9:57 a.m. UTC | #2
Am Mittwoch, dem 13.09.2023 um 11:43 -0400 schrieb Maxim Cournoyer:
> Hi,
> 
> Jack Hill <jackhill@jackhill.us> writes:
> 
> > * gnu/packages/gnome.scm (vala): Update to 0.56.13.
> > ---
> > 
> > I noticed that Dino was failing to build on the gnome-team branch.
> > It's
> > apparently because of some unintentional breaking changes in vala
> > 0.56.11 and 0.56.12. This patch updates vala to 0.56.13 which
> > restores
> > the previous behaviour.
> > 
> > https://github.com/dino/dino/issues/1479
> > https://gitlab.gnome.org/GNOME/vala/-/issues/1478
> > 
> > 
> >  gnu/packages/gnome.scm | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> > index ad118090eb..c9a4290472 100644
> > --- a/gnu/packages/gnome.scm
> > +++ b/gnu/packages/gnome.scm
> > @@ -4424,7 +4424,7 @@ (define-public seahorse
> >  (define-public vala
> >    (package
> >      (name "vala")
> > -    (version "0.56.12")
> > +    (version "0.56.13")
> >      (source (origin
> >                (method url-fetch)
> >                (uri (string-append "mirror://gnome/sources/vala/"
> > @@ -4432,7 +4432,7 @@ (define-public vala
> >                                    "vala-" version ".tar.xz"))
> >                (sha256
> >                 (base32
> > -               
> > "0n9m4l8d2n4wmgn9l5gdhnr6xl5ms7483ng5fxqak8xygi5xbjcj"))))
> > +               
> > "01xfarnhpp30wmv9mwayw8751glwppl0sva79j3y9qf76qq25229"))))
> >      (build-system glib-or-gtk-build-system)
> >      (arguments
> >       (list
> > 
> > base-commit: 20e3f3e1151b2f22ae7fb5aa8764148654f35090
> 
> LGTM!
Pushed.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad118090eb..c9a4290472 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4424,7 +4424,7 @@  (define-public seahorse
 (define-public vala
   (package
     (name "vala")
-    (version "0.56.12")
+    (version "0.56.13")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/vala/"
@@ -4432,7 +4432,7 @@  (define-public vala
                                   "vala-" version ".tar.xz"))
               (sha256
                (base32
-                "0n9m4l8d2n4wmgn9l5gdhnr6xl5ms7483ng5fxqak8xygi5xbjcj"))))
+                "01xfarnhpp30wmv9mwayw8751glwppl0sva79j3y9qf76qq25229"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      (list