diff mbox series

[bug#42274] gnu: zita-resampler: Update to 1.6.2.

Message ID efafd308ab274119a6304225b7c77b12b2a0a93a.camel@zrythm.org
State Accepted
Headers show
Series [bug#42274] gnu: zita-resampler: Update to 1.6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou July 8, 2020, 8:21 p.m. UTC
Hi,

This patch updates zita-resampler. The structure of the source code
changed so it required a few tweaks.

Thanks,
Alex

Comments

Efraim Flashner July 12, 2020, 6:35 p.m. UTC | #1
I made some changes to the commit message and adjusted the indentation
slightly in the patch. Patch pushed!
diff mbox series

Patch

From 53defb93bb80435e41b297b68cc1efd896060b8d Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 21:19:09 +0100
Subject: [PATCH] gnu: zita-resampler: Update to 1.6.2.

* gnu/packages/audio.scm (zita-resampler): Update to 1.6.2.
---
 gnu/packages/audio.scm | 23 +++++++++++++----------
 1 file changed, 13 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c96476857f..571624a622 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3203,7 +3203,7 @@  engine.")
 (define-public zita-resampler
   (package
     (name "zita-resampler")
-    (version "1.3.0")
+    (version "1.6.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -3213,33 +3213,36 @@  engine.")
               (snippet
                ;; Don't optimize for a specific processor architecture.
                '(begin
-                  (substitute* '("apps/Makefile" "libs/Makefile")
+                  (substitute* '("apps/Makefile" "source/Makefile")
                     (("^CXXFLAGS \\+= -march=native") ""))
                   #t))
               (modules '((guix build utils)))
               (sha256
                (base32
-                "0r9ary5sc3y8vba5pad581ha7mgsrlyai83w7w4x2fmhfy64q0wq"))))
+                "1my5k2dh2dkvjp6xjnf9qy6i7s28z13kw1n9pwa4a2cpwbzawfr3"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no "check" target
-       #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             (string-append "SUFFIX="))
        #:phases
        (modify-phases %standard-phases
          (add-after
           'unpack 'patch-makefile-and-enter-directory
           (lambda _
-            (substitute* "libs/Makefile"
-              (("ldconfig") "true")
-              (("^LIBDIR =.*") "LIBDIR = lib\n"))
-            (chdir "libs")
+            (substitute* "source/Makefile"
+                         (("ldconfig") "true")
+                         (("^LIBDIR =.*") "LIBDIR = lib\n"))
+            (chdir "source")
             #t))
          (add-after
           'install 'install-symlink
           (lambda _
             (symlink "libzita-resampler.so"
-                     (string-append (assoc-ref %outputs "out")
-                                    "/lib/libzita-resampler.so.1"))
+                     (string-append
+                       (assoc-ref %outputs "out")
+                       "/lib/libzita-resampler.so.1"))
             #t))
          ;; no configure script
          (delete 'configure))))
-- 
2.27.0