[bug#77371,09/12] gnu: Add python-particle.

Message ID efadf6728029ee8131188b71e1b60f71cd74fc89.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-particle): New variable.

Change-Id: Ib2462e25aadba797532c005a3b4d4e4a238a611e
---
 gnu/packages/python-science.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 876c68912a..b17c543619 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1143,6 +1143,34 @@  (define-public python-hepunits
 originally defined by the CLHEP project.")
     (license license:bsd-3)))
 
+(define-public python-particle
+  (package
+    (name "python-particle")
+    (version "0.25.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "particle" version))
+       (sha256
+        (base32 "1sb19sdng47ymh10r8b553xf8p0cqfs7j9qblh4fzsmz73pbp90z"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-attrs
+                             python-hepunits
+                             python-typing-extensions))
+    (native-inputs (list python-hatch-vcs
+                         python-hatchling
+                         python-pandas
+                         python-pytest
+                         python-pytest-benchmark
+                         python-tabulate))
+    (home-page "https://github.com/scikit-hep/particle")
+    (synopsis "Extended PDG particle data and MC identification codes")
+    (description
+     "@code{Particle} provides a pythonic interface to the Particle Data Group
+(PDG) particle data tables and particle identification codes, with extended
+particle information and extra goodies.")
+    (license license:bsd-3)))
+
 (define-public python-trimesh
   (package
     (name "python-trimesh")