diff mbox series

[bug#64053] gnu: fmt: Update to 10.0.0.

Message ID ef6f17c329231c34176fed03d773bded8d596c0f.1686682355.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#64053] gnu: fmt: Update to 10.0.0. | expand

Commit Message

Liliana Marie Prikler June 13, 2023, 6:43 p.m. UTC
* gnu/packages/pretty-print.scm (fmt-10): New variable.
(fmt-9): Inherit from fmt-10.
(fmt-8): Inherit from fmt-9.
(fmt-8.0, fmt-7): Inherit from fmt-8.
(fmt-6): Inherit from fmt-7.
(fmt): New variable.
---
 gnu/packages/pretty-print.scm | 30 +++++++++++++++++++++++-------
 1 file changed, 23 insertions(+), 7 deletions(-)


base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa
prerequisite-patch-id: af4df77b21fb893c5a269a41917db4168cfcb853

Comments

Ludovic Courtès June 20, 2023, 10:08 p.m. UTC | #1
Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/pretty-print.scm (fmt-10): New variable.
> (fmt-9): Inherit from fmt-10.
> (fmt-8): Inherit from fmt-9.
> (fmt-8.0, fmt-7): Inherit from fmt-8.
> (fmt-6): Inherit from fmt-7.
> (fmt): New variable.

LGTM, thanks!
Liliana Marie Prikler June 25, 2023, 12:38 p.m. UTC | #2
Am Mittwoch, dem 21.06.2023 um 00:08 +0200 schrieb Ludovic Courtès:
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/pretty-print.scm (fmt-10): New variable.
> > (fmt-9): Inherit from fmt-10.
> > (fmt-8): Inherit from fmt-9.
> > (fmt-8.0, fmt-7): Inherit from fmt-8.
> > (fmt-6): Inherit from fmt-7.
> > (fmt): New variable.
> 
> LGTM, thanks!
Welp, I messed up the commit message, but now it's too late to change
it.  *sigh*
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 74e51ec61e..3c53814013 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -167,17 +167,17 @@  (define-public enscript
 different programming languages.")
     (license gpl3+)))
 
-(define-public fmt
+(define-public fmt-10
   (package
     (name "fmt")
-    (version "9.1.0")
+    (version "10.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
                            version "/fmt-" version ".zip"))
        (sha256
-        (base32 "15n9yi6xzzs7g9rm87kg8y5yhl2zrqj3bjr845saa63f6swlrsyc"))))
+        (base32 "10f23avnpad8sakmq514w2bw6cw7xrb30kc3v8k7yn1zbwbcnhs9"))))
     (build-system cmake-build-system)
     (arguments '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
     (native-inputs (list unzip))
@@ -189,9 +189,21 @@  (define-public fmt
     ;; The library is bsd-2, but documentation and tests include other licenses.
     (license (list bsd-2 bsd-3 psfl))))
 
+(define-public fmt-9
+  (package
+    (inherit fmt-10)
+    (version "9.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+                           version "/fmt-" version ".zip"))
+       (sha256
+        (base32 "15n9yi6xzzs7g9rm87kg8y5yhl2zrqj3bjr845saa63f6swlrsyc"))))))
+
 (define-public fmt-8
   (package
-    (inherit fmt)
+    (inherit fmt-9)
     (version "8.1.1")
     (source
      (origin
@@ -203,7 +215,7 @@  (define-public fmt-8
 
 (define-public fmt-8.0
   (package
-    (inherit fmt)
+    (inherit fmt-8)
     (version "8.0.1")
     (source
      (origin
@@ -215,7 +227,7 @@  (define-public fmt-8.0
 
 (define-public fmt-7
   (package
-    (inherit fmt)
+    (inherit fmt-8)
     (version "7.1.3")
     (source
      (origin
@@ -227,7 +239,7 @@  (define-public fmt-7
 
 (define-public fmt-6
   (package
-    (inherit fmt)
+    (inherit fmt-7)
     (version "6.1.2")
     (source
      (origin
@@ -269,6 +281,10 @@  (define-public fmt-6
        ("libcxxabi" ,libcxxabi-6)
        ("clang" ,clang-6)))))
 
+;; Note: Updating fmt causes some 1000s of rebuilds, so let's have a pinned
+;; version.
+(define-public fmt fmt-9)
+
 (define-public source-highlight
   (package
     (name "source-highlight")