diff mbox series

[bug#64476,1/2] gnu: Add emacs-popwin.

Message ID ef6ec672bbe3ed5156fae2609c9628aec0534e51.1688561617.git.bjc@spork.org
State New
Headers show
Series gnu: Add emacs-popwin and emacs-elfeed-goodies | expand

Commit Message

Brian Cully July 5, 2023, 12:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-popwin): new variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6c86ee3793..d5cdea146a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13576,6 +13576,34 @@  (define-public emacs-find-file-in-project
 functions to assist in reviewing changes on files.")
     (license license:gpl3+)))
 
+(define-public emacs-popwin
+  (package
+    (name "emacs-popwin")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacsorphanage/popwin")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1x1iimzbwb5izbia6aj6xv49jybzln2qxm5ybcrcq7xync5swiv1"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:tests? #f ; requires an attached terminal
+      ))
+    (native-inputs
+     (list emacs-ert-runner))
+    (home-page "https://github.com/emacsorphanage/popwin")
+    (synopsis "Popup window manager for Emacs")
+    (description
+     "This package provides utilities for treating certain windows as @dfn{pop
+up windows}, which close automatically when quitting a command or selecting
+another window.")
+    (license license:gpl3+)))
+
 (define-public emacs-pyvenv
   (package
     (name "emacs-pyvenv")