diff mbox series

[bug#73931,v3,1/2] gnu: Add vdrift-data.

Message ID ef4b7a6d78768d791dab2772d555faa3d164e648.1729684359.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Add VDrift. | expand

Commit Message

Maxim Cournoyer Oct. 23, 2024, 11:53 a.m. UTC
* gnu/packages/games.scm (vdrift-data): New variable.

Change-Id: I960e2222ea7e9506a306692db552dc1dcc229b01
---
 gnu/packages/games.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 64b6b0941a..bbc0b9b09b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -788,6 +788,38 @@  (define-public tetrinet
 attacks you can use on opponents.")
     (license license:public-domain)))
 
+(define-public vdrift-data
+  ;; There are no tags or releases for the vdrift data; use the latest SVN
+  ;; revision available.
+  (let ((commit 1463)
+        (revision "0"))
+    ;; The package is hidden as the game data is *required* by the install
+    ;; target of vdrift itself, and there is no need for users to manually
+    ;; install it.
+    (hidden-package
+     (package
+       (name "vdrift-data")
+       ;; The date is the last modified time shown next to the 'vdrift-data'
+       ;; directory when visiting
+       ;; https://sourceforge.net/p/vdrift/code/HEAD/tree/.
+       (version (format #f "2024-10-23-~a.~a" revision commit))
+       (source (origin
+                 (method svn-fetch)
+                 (uri (svn-reference
+                       (url "https://svn.code.sf.net/p/vdrift/code/vdrift-data")
+                       (revision commit)))
+                 (file-name (string-append name "-" version "-checkout"))
+                 (sha256
+                  (base32
+                   "1zx08q4v3s4l5r0wxphd323h0rqp9pjb7kr08s3gb2qr85lw587h"))))
+       (build-system copy-build-system)
+       (arguments (list #:install-plan #~'(("." "share/games/vdrift/data"))))
+       (home-page "https://vdrift.net/")
+       (synopsis "Game data for Vdrift")
+       (description "This package contains the assets for the Vdrift racing
+game.")
+       (license license:gpl3+)))))      ;assumed same as Vdrift itself
+
 (define-public vitetris
   (package
     (name "vitetris")