diff mbox series

[bug#73287,v2,1/3] gnu: Add embree-2.

Message ID eeb7a4981f3393045f781e33851101ea81b52d15.1726879062.git.jsubuntuxp@disroot.org
State New
Headers show
Series [bug#73287,v2,1/3] gnu: Add embree-2. | expand

Commit Message

James Smith Sept. 21, 2024, 12:38 a.m. UTC
* gnu/packages/graphics.scm: (embree-2): New variable.

Change-Id: I2b2143b4d93c402ba940d408280ef1b37ab552ea
---
 gnu/packages/graphics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: e9d903f146865db5948abd271a5c7e763681b4e9
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index edaa905c7a..171cbce24d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2023 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -490,6 +491,27 @@  (define-public embree-3
                (base32
                 "1kcvz7g6j56anv9zjyd3gidxl46vipw0gg82lns12m45cd43iwxm"))))))
 
+(define-public embree-2
+  (package/inherit embree
+    (version "2.17.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference (url "https://github.com/RenderKit/embree")
+                           (commit (string-append "v" version))))
+       (file-name (git-file-name (package-name embree) version))
+       (sha256
+        (base32 "19v60zdfix33c772x6dzmhsarhafsns8qy7c2ysqr7a9j16whgql"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments embree)
+       ((#:configure-flags configure-flags)
+        #~(append (list "-DEMBREE_MAX_ISA=NONE" "-DEMBREE_TUTORIALS=OFF")
+              #$configure-flags))))
+    (inputs (modify-inputs (package-inputs embree)
+              (replace "tbb" tbb-2020)))
+    ;; Embree requires SSE2 support, so build only for x86-based architectures.
+    (supported-systems (list "i686-linux" "x86_64-linux"))))
+
 (define-public openvdb
   (package
     (name "openvdb")