diff mbox series

[bug#63185] gnu: Add pastel.

Message ID eeb59d81b8b70a3b7f0bc77e26b1051c06f145fa.1682829660.git.guix@bassamsaeed.ca
State New
Headers show
Series [bug#63185] gnu: Add pastel. | expand

Commit Message

Bassam Saeed April 30, 2023, 4:41 a.m. UTC
* gnu/packages/rust-apps.scm (pastel): New variable.
---
 gnu/packages/rust-apps.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 309d8294e93ddf46eb690e7cf4202857ad5f7f55
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 73ed31c60c..d851fbd821 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2314,3 +2314,37 @@  (define-public htmlq
     (synopsis "Like jq, but for HTML")
     (description "Extract content from HTML files using CSS selectors.")
     (license license:expat)))
+
+(define-public pastel
+  (package
+    (name "pastel")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pastel" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fjlw8np2bx0i1hk6lfq5swiif6ilj9f270vfh8yr62apq704g0f"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-atty" ,rust-atty-0.2)
+                       ("rust-clap" ,rust-clap-3)
+                       ("rust-clap-complete" ,rust-clap-complete-3)
+                       ("rust-nom" ,rust-nom-7)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-output-vt100" ,rust-output-vt100-0.1)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-regex" ,rust-regex-1))
+       #:cargo-development-inputs (("rust-approx" ,rust-approx-0.5)
+                                   ("rust-assert-cmd" ,rust-assert-cmd-2)
+                                   ("rust-rand-xoshiro" ,rust-rand-xoshiro-0.6))))
+    (home-page "https://github.com/sharkdp/pastel")
+    (synopsis
+     "Command-line tool to generate, analyze, convert and manipulate colors")
+    (description
+     "pastel is a command-line tool to generate, analyze, convert and
+manipulate colors.  It supports many different color formats and color spaces
+like RGB (sRGB), HSL, CIELAB, CIELCh as well as ANSI 8-bit and 24-bit
+representations.")
+    (license (list license:expat license:asl2.0))))