diff mbox series

[bug#50495,1/4] gnu: go-github-com-keybase-go-ps: Patch for go@1.17.

Message ID ee9ec2d42f0c8d52c0b1a516461386597f8ab55e.1631234078.git.iskarian@mgsn.dev
State Accepted
Headers show
Series gnu: Fix some builds with go@1.17. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Sept. 10, 2021, 12:50 a.m. UTC
* gnu/packages/golang.scm (go-github-com-keybase-go-ps)[arguments]
<#:phases>{fix-tests}: Remove extraneous build line to appease go@1.17.
---
 gnu/packages/golang.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2dfd47d396..4577c49cba 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1597,7 +1597,9 @@  (define-public go-github-com-keybase-go-ps
                  (("/bin/sleep" command)
                   (string-append
                    (assoc-ref (or native-inputs inputs) "coreutils")
-                   command))))))))
+                   command)))
+               (substitute* "src/github.com/keybase/go-ps/process_openbsd.go"
+                 (("^// \\+build ignore") "")))))))
       (native-inputs
        `(("coreutils" ,coreutils)
          ("go-github-com-stretchr-testify"