diff mbox series

[bug#62900,v2] Upgrade python-anyio to 3.6.2

Message ID ee9c4abc6a9edc040b7ec97ce9617f91e01cfab5.1681974787.git.hugo@buddelmeijer.nl
State New
Headers show
Series [bug#62900,v2] Upgrade python-anyio to 3.6.2 | expand

Commit Message

Hugo Buddelmeijer April 20, 2023, 8:32 a.m. UTC
---

Thank you Greg. I'm a bit puzzled too (and embarashed).

Attached is the patch with the corrected hash. However, it has the same
problems as 3.5.0 so it is perhaps not worth it to merge this patch.

The mismatching hash is due to me trying to learn everything at the same
time: guix, scheme, emacs. I'm used to copy pasting with ctrl-insert
shift-insert and removing text with ctrl-backspace (IBM Common User
Access). With my muscle memory failing me, I botched changing the hash.

However, I believed I fixed the hash, and built the package, also with
 --rounds=2, otherwise I would not have submitted the patch. At least,
that's what I thought, but apparently I did not and wasted your time.
My apologies for that; I'll be more careful in the future.

Now that I've submitted a broken patch, would that be noticed somewhere
automatically? The linter on qa.guix.gnu.org seems to be fine with it.
Or are patched packages not build automatically?

As about why the derivation changed, perhaps that is because
python-trio has been updated to 0.22? I don't yet fully understand how
these derivation work.

Once again my apologies, I feel bad for messing this patch up.

Hugo


 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 9a5e1dc1f16f5f8c056e64f2077b035784003673
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0147870b06..0c2ec44db3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25711,14 +25711,14 @@  (define-public python-iocapture
 (define-public python-anyio
   (package
     (name "python-anyio")
-    (version "3.5.0")
+    (version "3.6.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "anyio" version))
        (sha256
         (base32
-         "19m58805wir4i2s45dd5ynwlzb7ky1218isbir53gpqzzgigzbm0"))))
+         "08bljjq5xq0l9id36q3vvjgygirq7g7q2bs41hdg82p379khvsi5"))))
     (build-system python-build-system)
     (arguments
      `(#:phases