diff mbox series

[bug#65828,gnome-team,v4,2/3] gnu: gegl: Add version 0.4.44 for gnome-photos.

Message ID ee625fce9bd09def9ed4b45da30c088ec5f721d4.1694559697.git.vivien@planete-kraus.eu
State New
Headers show
Series Gegl 0.4.46 does not work yet with gnome-photos | expand

Commit Message

Vivien Kraus Sept. 12, 2023, 10:52 p.m. UTC
* gnu/packages/gimp.scm (gegl-0.4.44): New variable.
* gnu/packages/gnome.scm (gnome-photos) [inputs]: Use gegl-0.4.44, not gegl.
---
 gnu/packages/gimp.scm  | 21 +++++++++++++++++++++
 gnu/packages/gnome.scm |  2 +-
 2 files changed, 22 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Sept. 13, 2023, 4:18 a.m. UTC | #1
Am Mittwoch, dem 13.09.2023 um 00:52 +0200 schrieb Vivien Kraus:
> * gnu/packages/gimp.scm (gegl-0.4.44): New variable.
> * gnu/packages/gnome.scm (gnome-photos) [inputs]: Use gegl-0.4.44,
> not gegl.
> ---
>  gnu/packages/gimp.scm  | 21 +++++++++++++++++++++
>  gnu/packages/gnome.scm |  2 +-
>  2 files changed, 22 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
> index 167de97ec5..0bc58e0ddf 100644
> --- a/gnu/packages/gimp.scm
> +++ b/gnu/packages/gimp.scm
> @@ -287,6 +287,27 @@ (define-public gegl
>      ;; application and GUI binary gegl is licensed under GPL.
>      (license (list license:lgpl3+ license:gpl3+))))
>  
> +;; gnome-photos does not build against gegl 0.4.46 yet.
> +;; https://gitlab.gnome.org/GNOME/gnome-photos/-/issues/214
> +(define-public gegl-0.4.44
> +  (package
> +    (inherit gegl)
> +    (version "0.4.44")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (list (string-append
> "https://download.gimp.org/pub/gegl/"
> +                                 (string-take version 3)
> +                                 "/gegl-" version ".tar.xz")
> +                  (string-append "https://ftp.gtk.org/pub/gegl/"
> +                                 (version-major+minor version)
> +                                 "/gegl-" version ".tar.xz")
> +                  (string-append "ftp://ftp.gtk.org/pub/gegl/"
> +                                 (version-major+minor version)
> +                                 "/gegl-" version ".tar.xz")))
This should be squashed into the previous commit so as to not break
gnome-photos in the meantime.

Cheers
Vivien Kraus Sept. 14, 2023, 5:02 a.m. UTC | #2
Hi!

Le mercredi 13 septembre 2023 à 06:18 +0200, Liliana Marie Prikler a
écrit :
> This should be squashed into the previous commit so as to not break
> gnome-photos in the meantime.

QA seems to fail:

https://qa.guix.gnu.org/issue/65828

However, if we look in details, the branch that QA decided to build did
not pick up the commit to fix gnome-photos (the new package failure).
Presumably because I sent the latest series while it was still
evaluating a previous one.

Is there a way to restart it?

Vivien
Liliana Marie Prikler Sept. 15, 2023, 4:20 a.m. UTC | #3
Am Donnerstag, dem 14.09.2023 um 07:02 +0200 schrieb Vivien Kraus:
> Hi!
> 
> Le mercredi 13 septembre 2023 à 06:18 +0200, Liliana Marie Prikler a
> écrit :
> > This should be squashed into the previous commit so as to not break
> > gnome-photos in the meantime.
> 
> QA seems to fail:
> 
> https://qa.guix.gnu.org/issue/65828
> 
> However, if we look in details, the branch that QA decided to build
> did not pick up the commit to fix gnome-photos (the new package
> failure).  Presumably because I sent the latest series while it was
> still evaluating a previous one.
> 
> Is there a way to restart it?
> 
> Vivien
Don't worry about it, I've confirmed that it builds locally.  It will
likely pick up the pace either later or at the very least after I've
pushed it to gnome-team.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 167de97ec5..0bc58e0ddf 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -287,6 +287,27 @@  (define-public gegl
     ;; application and GUI binary gegl is licensed under GPL.
     (license (list license:lgpl3+ license:gpl3+))))
 
+;; gnome-photos does not build against gegl 0.4.46 yet.
+;; https://gitlab.gnome.org/GNOME/gnome-photos/-/issues/214
+(define-public gegl-0.4.44
+  (package
+    (inherit gegl)
+    (version "0.4.44")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (list (string-append "https://download.gimp.org/pub/gegl/"
+                                 (string-take version 3)
+                                 "/gegl-" version ".tar.xz")
+                  (string-append "https://ftp.gtk.org/pub/gegl/"
+                                 (version-major+minor version)
+                                 "/gegl-" version ".tar.xz")
+                  (string-append "ftp://ftp.gtk.org/pub/gegl/"
+                                 (version-major+minor version)
+                                 "/gegl-" version ".tar.xz")))
+       (sha256
+        (base32 "09k1sn4h0bakgmq2hgd1iamprngpr81ky3fd9446lh2ycd0xnk0a"))))))
+
 (define-public gimp
   (package
     (name "gimp")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad118090eb..0f149e69b5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -855,7 +855,7 @@  (define-public gnome-photos
     (inputs
      (list babl
            cairo
-           gegl
+           gegl-0.4.44
            geocode-glib
            gexiv2
            gfbgraph