[bug#78337,core-packages-team,1/4] gnu: curl: Ungraft.
Commit Message
* gnu/packages/curl.scm (curl)[replacement]: Remove it.
[source]: Add curl-CVE-2024-8096.patch.
* gnu/packages/curl.scm (curl/fixed): Remove it.
Change-Id: I43e6c1c0c97bc86ce0e4801559eead53a1a07d12
---
gnu/packages/curl.scm | 14 ++------------
1 file changed, 2 insertions(+), 12 deletions(-)
@@ -69,7 +69,6 @@ (define-public curl
(package
(name "curl")
(version "8.6.0")
- (replacement curl/fixed)
(source (origin
(method url-fetch)
(uri (string-append "https://curl.se/download/curl-"
@@ -77,7 +76,8 @@ (define-public curl
(sha256
(base32
"05fv468yjrb7qwrxmfprxkrcckbkij0myql0vwwnalgr3bcmbk9w"))
- (patches (search-patches "curl-use-ssl-cert-env.patch"))))
+ (patches (search-patches "curl-use-ssl-cert-env.patch"
+ "curl-CVE-2024-8096.patch"))))
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
(build-system gnu-build-system)
@@ -179,16 +179,6 @@ (define-public curl
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
-(define-public curl/fixed
- (hidden-package
- (package
- (inherit curl)
- (replacement curl/fixed)
- (source (origin
- (inherit (package-source curl))
- (patches (append (origin-patches (package-source curl))
- (search-patches "curl-CVE-2024-8096.patch"))))))))
-
(define-public gnurl (deprecated-package "gnurl" curl))
(define-public curl-ssh