diff mbox series

[bug#71423,2/2] gnu: Add itamae.

Message ID ee1568e6f5b5cd85a8942839369c4d6813bc9da0.1717804696.git.gemmaro.dev@gmail.com
State New
Headers show
Series gnu: Add itamae. | expand

Commit Message

gemmaro June 8, 2024, 12:24 a.m. UTC
* gnu/packages/admin.scm (itamae): New variable.

Change-Id: I8648f7d0eb12a1e63af2e1cf9811a7dadcee2e43
---
 gnu/packages/admin.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c730d43819..1d26b1de40 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3150,6 +3151,36 @@  (define-public emacs-ansible-doc
 'yaml-mode-hook #'ansible-doc-mode)}.")
       (license license:gpl3+))))
 
+(define-public itamae
+  (package
+    (name "itamae")
+    (version "1.14.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "itamae" version))
+       (sha256
+        (base32 "1zhx0cknipkjqp33qdxjlv7lcybgmh1jv9npp55vxaazd8cyfylx"))))
+    (build-system ruby-build-system)
+    (arguments
+     (list
+      #:test-target "spec:unit"
+      #:phases #~(modify-phases %standard-phases
+                   ;; There hasn't been the Fluentd packages yet.
+                   (add-before 'check 'remove-fluentd-related-files
+                     (lambda _
+                       (delete-file
+                        "spec/unit/lib/itamae/handler/fluentd_spec.rb"))))))
+    (native-inputs (list ruby-rspec ruby-fakefs))
+    (propagated-inputs (list ruby-ansi ruby-hashie ruby-schash ruby-specinfra
+                             ruby-thor))
+    (synopsis "Simple and lightweight configuration management tool")
+    (description
+     "Itamae is a configulation management tool inspired by Chef, but simpler and
+lightweight.")
+    (home-page "https://itamae.kitchen/")
+    (license license:expat)))
+
 (define-public cpulimit
   (package
     (name "cpulimit")