diff mbox series

[bug#67592,09/20] gnu: rust-zerocopy-derive: Update to 0.7.29.

Message ID ee10b4c8954360120278ec06a76e65fa8f1da4fe.1702415474.git.rteissier.code@chillpc.fr
State New
Headers show
Series gnu: rust-git2: Update to 0.18.1 | expand

Commit Message

RĂ©mi Teissier Dec. 12, 2023, 9:16 p.m. UTC
Change-Id: I0f0defb596f04e95fee9d3a866a6c4ea483ea2fb
---
 gnu/packages/crates-io.scm | 30 +++++++++++++++++++++++++-----
 1 file changed, 25 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4d2091fd850..40151728504 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -85592,24 +85592,24 @@  (define-public rust-zerocopy-0.3
         ("rust-zerocopy-derive" ,rust-zerocopy-derive-0.2))))
     (license license:bsd-3)))
 
-(define-public rust-zerocopy-derive-0.3
+(define-public rust-zerocopy-derive-0.7
   (package
     (name "rust-zerocopy-derive")
-    (version "0.3.2")
+    (version "0.7.29")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "zerocopy-derive" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "18qr7dqlj89v1xl1g58l2xd6jidv0sbccscgl131gpppba0yc1b5"))))
+                "1hmh2fl264i1rdn67jvlx34niyhix3pnbbfk17prfywrfsh5rkc6"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-proc-macro2" ,rust-proc-macro2-1)
-        ("rust-syn" ,rust-syn-1)
-        ("rust-synstructure" ,rust-synstructure-0.12))))
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-2))))
     (home-page "https://github.com/google/zerocopy")
     (synopsis "Custom derive for traits from the zerocopy Rust crate")
     (description
@@ -85617,6 +85617,26 @@  (define-public rust-zerocopy-derive-0.3
 crate.")
     (license license:bsd-2)))
 
+(define-public rust-zerocopy-derive-0.3
+  (package
+    (inherit rust-zerocopy-derive-0.7)
+    (name "rust-zerocopy-derive")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "zerocopy-derive" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "18qr7dqlj89v1xl1g58l2xd6jidv0sbccscgl131gpppba0yc1b5"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-syn" ,rust-syn-1)
+        ("rust-synstructure" ,rust-synstructure-0.12))))))
+
 (define-public rust-zerocopy-derive-0.2
   (package
     (inherit rust-zerocopy-derive-0.3)