diff mbox series

[bug#49989,v2] gnu: go-torproject-org-pluggable-transports-goptlib: Fix import path.

Message ID ee0f780a53c9888f85cebc76d6c8cf8e0264a91b.1628829129.git.iskarian@mgsn.dev
State New
Headers show
Series [bug#49989,v2] gnu: go-torproject-org-pluggable-transports-goptlib: Fix import path. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Aug. 13, 2021, 4:37 a.m. UTC
* gnu/packages/golang.scm (go-torproject-org-pluggable-transports-goptlib)
[arguments]<#:import-path>: Use actual module name from go.mod.
(go-github-com-operatorfoundation-shapeshifter-transports)[arguments]
<#:phases>: Remove obsolete 'patch phase for goptlib.
(go-github-com-operatorfoundation-obfs4)[arguments]<#:phases>: Likewise.
---
Since it will break builds if these are applied separately, I went ahead and
merged these into one commit.

 gnu/packages/golang.scm | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)


base-commit: d87d6d68128c53a95fe09c3a4381575646c0f368
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f4cd30c662..20c8a519dc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -661,11 +661,6 @@  filtering devices.")
      `(#:unpack-path "github.com/OperatorFoundation/shapeshifter-transports"
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             (substitute* (find-files "." "\\.go$")
-               ;; To drop '.git' suffix in import path of goptlib.
-               (("goptlib\\.git") "goptlib"))))
          (replace 'build
            (lambda arguments
              (for-each
@@ -1205,11 +1200,6 @@  protocol from the Pluggable Transports 2.0 specification.")
      `(#:unpack-path "github.com/OperatorFoundation/obfs4"
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             (substitute* (find-files "." "\\.go$")
-               ;; To drop '.git' suffix in import path of goptlib.
-               (("goptlib\\.git") "goptlib"))))
          (replace 'build
            (lambda arguments
              (for-each
@@ -1356,7 +1346,7 @@  parsing and encoding support for STUN and TURN protocols.")
         (base32 "1lh938194hvkf8pqgnxwf6hvjv9rv0j3kasi07r2ckrj8sxzk4jc"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "git.torproject.org/pluggable-transports/goptlib"))
+     `(#:import-path "git.torproject.org/pluggable-transports/goptlib.git"))
     (home-page "https://gitweb.torproject.org/pluggable-transports/goptlib.git/")
     (synopsis "Go pluggable transports library")
     (description "GoPtLib is a library for writing Tor pluggable transports in