[bug#77154,v3,2/2] gnu: libssh2: Change crypto backend to openssl
Commit Message
* gnu/packages/ssh.scm (libssh2): Change crypto backend to openssl
[arguments]: Replace libgcrypt with openssl
[propagated-inputs]: Replace libgcrypt with openssl
Change crypto backend to openssl to support ed25519 hostkeys.
Change-Id: I7603149d6e3a3c251bdc6c3238769a63b6a04d26
---
gnu/packages/ssh.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
@@ -193,9 +193,9 @@ (define-public libssh2
(build-system gnu-build-system)
;; The installed libssh2.pc file does not include paths to libgcrypt and
;; zlib libraries, so we need to propagate the inputs.
- (propagated-inputs (list libgcrypt zlib))
+ (propagated-inputs (list openssl zlib))
(arguments
- (list #:configure-flags #~'("--with-libgcrypt"
+ (list #:configure-flags #~'("--with-crypto=openssl"
"--disable-static"
"--disable-docker-tests" )))
(synopsis "Client-side C library implementing the SSH2 protocol")