diff mbox series

[bug#66037,v2,3/3] gnu: osmium-tool: Update to 1.15.0.

Message ID eda4d3e8c026599a41e692644b9edac71a831406.1694978682.git.hendursaga@aol.com
State New
Headers show
Series Update libosmium and dependents | expand

Commit Message

Hendursaga Sept. 17, 2023, 7:39 p.m. UTC
gnu/packages/geo.scm (osmium-tool): Update to 1.15.0.
---
 gnu/packages/geo.scm | 35 ++++++++++++++++-------------------
 1 file changed, 16 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c7ee877a1e..8ee3b1a7ec 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1567,26 +1567,23 @@  (define-public libosmium
 (define-public osmium-tool
   (package
     (name "osmium-tool")
-    (version "1.14.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/osmcode/osmium-tool")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0zgyqyrs89vch0qnkh9m5xq079sr2wmydy5zz4l8xbysbjf6xry5"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; Remove bundled libraries.
-        '(delete-file-recursively "include/rapidjson"))))
+    (version "1.15.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/osmcode/osmium-tool")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d90vz316xdl3c416nicgdw7ybw17l2125wgxglbzl7jaqngapy5"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove bundled libraries.
+               '(delete-file-recursively "include/rapidjson"))))
     (build-system cmake-build-system)
-    (inputs
-     (list libosmium
-           rapidjson))
-    (native-inputs
-     (list pandoc))
+    (inputs (list libosmium rapidjson))
+    (native-inputs (list pandoc))
     (home-page "https://osmcode.org/osmium-tool/")
     (synopsis "Osmium command-line tool")
     (description "Command line tool for working with OpenStreetMap data