diff mbox series

[bug#65458] gnu: granite: Upgrade to 7.3.0.

Message ID eda48b266f54453081210f4005776ac93cbcdec4.1692732384.git.altadil@protonmail.com
State New
Headers show
Series [bug#65458] gnu: granite: Upgrade to 7.3.0. | expand

Commit Message

altadil Aug. 22, 2023, 7:35 p.m. UTC
* gnu/packages/pantheon.scm (granite): Upgrade to 7.3.0.
---
This is a work in progress, as I have noted two problems.
First is: guix lint says
"label 'glib' does not match package name 'glib:bin"
but looking at the package reference in the manual,
I don’t get why the way I wrote it is wrong.
Second: guix size reports a doubled size, but I don’t
know if anything can be done about it.

 gnu/packages/pantheon.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)


base-commit: 0c4fb8f43f8aba2dcabe1bc97a8f6d8d41057704

Comments

Maxim Cournoyer Sept. 2, 2023, 3:26 a.m. UTC | #1
Hi,

altadil <Altadil@protonmail.com> writes:

> * gnu/packages/pantheon.scm (granite): Upgrade to 7.3.0.
> ---
> This is a work in progress, as I have noted two problems.
> First is: guix lint says
> "label 'glib' does not match package name 'glib:bin"
> but looking at the package reference in the manual,
> I don’t get why the way I wrote it is wrong.

The glib:bin lint warning can be ignored.  It's a long standing issue.

> Second: guix size reports a doubled size, but I don’t
> know if anything can be done about it.

GTK (4) needs some size work.  It appear this may have broke some other
dependent packages such as pantheon-calculator, maybe because of the
mismatched GTK version used.  We'll have to see what the QA says after
it has processed it (https://qa.guix.gnu.org/issue/65458).
altadil Sept. 2, 2023, 1:29 p.m. UTC | #2
> Hi,
> 
> altadil Altadil@protonmail.com writes:
> 
> > * gnu/packages/pantheon.scm (granite): Upgrade to 7.3.0.
> > ---
> > This is a work in progress, as I have noted two problems.
> > First is: guix lint says
> > "label 'glib' does not match package name 'glib:bin"
> > but looking at the package reference in the manual,
> > I don’t get why the way I wrote it is wrong.
> 
> 
> The glib:bin lint warning can be ignored. It's a long standing issue.
> 
> > Second: guix size reports a doubled size, but I don’t
> > know if anything can be done about it.
> 
> 
> GTK (4) needs some size work. It appear this may have broke some other
> dependent packages such as pantheon-calculator, maybe because of the
> mismatched GTK version used. We'll have to see what the QA says after
> it has processed it (https://qa.guix.gnu.org/issue/65458).
> 
> --
> Thanks,
> Maxim

Hi,

my goal in updating granite was actually to be able to upgrade pantheon-calculator to its latest upstream version. So I guess I’ll go work on that as soon as I can.

Thanks a lot for your help !
Altadil
Maxim Cournoyer Sept. 6, 2023, 3:07 a.m. UTC | #3
Hello,

Installed with cc3fbfbb2.  I needed to propagate gtk and others, which
were referenced in the pkg-config file and causing sideload to break.
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 1c6795cc1d..c5cbde24c0 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages pantheon)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages)
   #:use-module (guix build-system meson)
   #:use-module (guix git-download)
@@ -40,7 +41,7 @@  (define-module (gnu packages pantheon)
 (define-public granite
   (package
     (name "granite")
-    (version "6.2.0")
+    (version "7.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -49,16 +50,20 @@  (define-public granite
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+                "0pyvkif2kin5dskh7adadsh4r96mvx12y7cs6gnm0ml733q548dj"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after 'unpack 'disable-icon-cache
                     (lambda _
                       (setenv "DESTDIR" "/"))))))
-    (inputs (list glib gtk+ libgee))
-    (native-inputs (list gettext-minimal gobject-introspection pkg-config
-                         python vala))
+    (inputs (list glib gtk libgee sassc))
+    (native-inputs (list gettext-minimal
+                         `(,glib "bin")
+                         gobject-introspection
+                         pkg-config
+                         python
+                         vala))
     (home-page "https://github.com/elementary/granite")
     (synopsis "Library that extends GTK with common widgets and utilities")
     (description "Granite is a companion library for GTK+ and GLib.  Among other