diff mbox series

[bug#66870,v3,3/7] gnu: Add function2.

Message ID eda28672b93c14b67a5acc639fd6f52ed51cfe2d.1701340263.git.sughosha@disroot.org
State New
Headers show
Series [bug#66870,v3,1/7] gnu: asio: Update to 1.28.0. | expand

Commit Message

Sughosha Nov. 30, 2023, 10:32 a.m. UTC
From: Sughosha <sughosha@proton.me>

* gnu/packages/cpp.scm (function2): New variable.

Change-Id: I29eb928aa943fa6b796d699271ca523075d44d38
---
 gnu/packages/cpp.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 16fd5bcec5..24e519b10b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2343,6 +2343,36 @@  (define-public bitsery
     (home-page "https://github.com/fraillt/bitsery")
     (license license:expat)))
 
+(define-public function2
+  (package
+    (name "function2")
+    (version "4.2.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Naios/function2")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15k8i872s2jpwbpxfq42lr96q9wplvr8gjs2msf5i4ylyp846dgf"))))
+    (build-system cmake-build-system)
+    ;; The test size_match_layout fails on i586/i686. For more info:
+    ;; https://github.com/Naios/function2/issues/57
+    (arguments
+     (list #:tests? #f))
+    (synopsis "Improved implementations of std::function")
+    (description "This package provides the following implementations of
+std::function:
+@itemize
+@item copyable fu2::function
+@item move-only fu2::unique_function (capable of holding move only types)
+@item non-owning fu2::function_view (capable of referencing callables in a non
+owning way)
+@end itemize")
+    (home-page "https://naios.github.io/function2/")
+    (license license:boost1.0)))
+
 (define-public cpp-mustache
   (package
     (name "cpp-mustache")