diff mbox series

[bug#69504] gnu: Add wbg.

Message ID ed742e3b23225a653b996b22d91dcb1c7db23e36.1709372736.git.i@dan.games
State New
Headers show
Series [bug#69504] gnu: Add wbg. | expand

Commit Message

dan March 2, 2024, 9:45 a.m. UTC
* gnu/packages/wm.scm (wbg): New variable.

Change-Id: Ib20af5fee37ab258224ead6caf35af3b9c78e802
---
 gnu/packages/wm.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8ed3ed1107..ce0ba981f5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2024 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2024 chris <chris@bumblehead.com>
+;;; Copyright © 2024 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3723,3 +3724,30 @@  (define-public yambar-wayland
 for short) for X11 and Wayland, that goes to great lengths to be both CPU and
 battery efficient---polling is only done when absolutely necessary.")
     (license license:expat)))
+
+(define-public wbg
+  (package
+    (name "wbg")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/dnkl/wbg")
+             (commit version)))
+       (sha256
+        (base32 "0rq2m2cddggmxq77pfks1mga3y7a54pnm2linqipia1l4ylhi4i4"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:build-type "release"
+      #:configure-flags #~(list "-Dpng=enabled" "-Djpeg=enabled"
+                                "-Dwebp=enabled")))
+    (native-inputs (list pkg-config tllist wayland-protocols))
+    (inputs (list libjpeg-turbo libpng libwebp pixman wayland))
+    (home-page "https://codeberg.org/dnkl/wbg")
+    (synopsis "Wallpaper application for Wayland compositors")
+    (description
+     "wbg is a super simple wallpaper application for Wayland compositors
+implementing the layer-shell protocol.")
+    (license license:expat)))