diff mbox series

[bug#65556,v1] gnu: Add Sirikali.

Message ID ed70c7e18adae6ce7bd22aacddbec403b8f4f683.1700536912.git.aarcov@gmail.com
State New
Headers show
Series [bug#65556,v1] gnu: Add Sirikali. | expand

Commit Message

Aaron Covrig Nov. 21, 2023, 3:21 a.m. UTC
From: Aaron Covrig <aaron.covrig.us@ieee.org>

* gnu/packages/file-systems.scm (sirikali): New variable

Change-Id: Ie46cf269dac1ba842d935221b2372fb3d8a6ea2d
---
I have updated the patch to now use the new location and changed the    
commit message to match the format I'm seeing in the commit logs (I 
haven't seen a specific commit structure in 
https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html
or https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html), 
let me know if there is documentation on the prefered commit structure 
and such as I am looking to send in some more patches and updates as time goes on.

Additionally, the 'Comment' message was more intended as extra details
to explain why I wished to include this software, not so much as the 
'Description' field; I'm assuming that this is something that I can put 
into this 'annotation' field going forward?

V/r,

Aaron Covrig

 gnu/packages/file-systems.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: d987b75618a62c95c030e7ca53e0972e700c4f06
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc061a5958..aaf2f2ff21 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;; Copyright © 2021, 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;; Copyright © 2022 Brian Cully <bjc@spork.org>
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,8 +65,10 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-check)
@@ -81,6 +84,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages nfs)
   #:use-module (gnu packages onc-rpc)
   #:use-module (gnu packages openldap)
+  #:use-module (gnu packages password-utils)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages photo)
@@ -91,6 +95,7 @@  (define-module (gnu packages file-systems)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rsync)
   #:use-module (gnu packages sssd)
@@ -2112,3 +2117,30 @@  (define-public dwarfs
 
 @end itemize\n")
     (license license:gpl3)))
+
+(define-public sirikali
+  (package
+    (name "sirikali")
+    (version "1.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mhogomchungu/sirikali")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1l52s8rxkfcxcx3s2fnsh08wy6hhjjvp7gcggdi84aqc4dq3rdnm"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f ;No tests
+       #:configure-flags '("-DQT5=true" "-DCMAKE_BUILD_TYPE=RELEASE")))
+    (inputs (list xdg-utils libpwquality libgcrypt libsecret qtbase-5))
+    (native-inputs (list pkg-config))
+    (home-page "https://mhogomchungu.github.io/sirikali/")
+    (synopsis
+     "GUI front end to sshfs, ecryptfs, cryfs, gocryptfs, securefs, fscrypt and encfs")
+    (description "@dfn{SiriKali} is a Qt/C++ GUI application that manages
+ecryptfs, cryfs, encfs, gocryptfs, fscrypt and securefs
+based encrypted folders")
+    (license (list license:gpl3 license:gpl2))))