[bug#77287,v2,7/8] gnu: hdf5: Make hdf@1.14 the default version.
Commit Message
This replaces all inputs hdf5@1.10 by hdf5@1.14 unless explicitly
specified otherwise.
* gnu/packages/maths.scm (hdf5-1.14): Rename to...
(hdf5): ...this, which was previously defined as hdf5-1.10.
(hdf-eos5, hdf5-parallel-openmpi, scilab): Adapt variable names.
(hdf-java)[inputs]: Keep hdf5-1.10.
* gnu/packages/bioinformatics.scm (fast5, ncbi-vdb),
gnu/packages/cran.scm (r-h5), gnu/packages/image.scm (vigra)[inputs]:
Keep hdf5-1.10.
Change-Id: Ie43a13ecbb4da597ec1d3f7c0428102b45881485
---
gnu/packages/bioinformatics.scm | 4 ++--
gnu/packages/cran.scm | 2 +-
gnu/packages/image.scm | 2 +-
gnu/packages/maths.scm | 16 ++++++----------
4 files changed, 10 insertions(+), 14 deletions(-)
@@ -7941,7 +7941,7 @@ (define-public fast5
(add-after 'unpack 'chdir
(lambda _
(chdir "python"))))))
- (inputs (list hdf5))
+ (inputs (list hdf5-1.10))
(propagated-inputs
(list python-dateutil))
(native-inputs
@@ -11349,7 +11349,7 @@ (define-public ncbi-vdb
(install-file "libs/kfg/default.kfg" target)
(install-file "libs/kfg/certs.kfg" target)))))))
(inputs
- (list file hdf5 java-ngs libxml2 ngs-sdk ))
+ (list file hdf5-1.10 java-ngs libxml2 ngs-sdk ))
(native-inputs (list perl))
;; NCBI-VDB requires SSE capability.
(supported-systems '("i686-linux" "x86_64-linux"))
@@ -14934,7 +14934,7 @@ (define-public r-h5
"14p7i1sj24ky87kd7qr3n9fc9l64s0bp0rwbyl6i2x69xn75gpsx"))))
(build-system r-build-system)
(inputs
- (list zlib hdf5))
+ (list zlib hdf5-1.10))
(native-inputs
(list r-knitr r-testthat which))
(propagated-inputs
@@ -1389,7 +1389,7 @@ (define-public vigra
`(("boost" ,boost)
("fftw" ,fftw)
("fftwf" ,fftwf)
- ("hdf5" ,hdf5)
+ ("hdf5" ,hdf5-1.10)
("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
; to create a configure-flag
("libjpeg" ,libjpeg-turbo)
@@ -1834,7 +1834,7 @@ (define-public hdf5-1.10
(base32 "14gih7kmjx4h3lc7pg4fwcl28hf1qqkf2x7rljpxqvzkjrqbxi00"))
(patches (search-patches "hdf5-config-date.patch"))))))
-(define-public hdf5-1.14
+(define-public hdf5
(package
(inherit hdf5-1.8)
(version "1.14.3")
@@ -1872,10 +1872,6 @@ (define-public hdf5-1.14
(("@UNAME_INFO@")
"Linux"))))))))))
-(define-public hdf5
- ;; Default version of HDF5.
- hdf5-1.10)
-
;; Keep this in sync with the current hdf5 package.
(define-public hdf-java
(package
@@ -1963,7 +1959,7 @@ (define-public hdf-java
java-slf4j-simple))
(inputs
(list hdf4
- hdf5
+ hdf5-1.10
java-slf4j-api
libjpeg-turbo
zlib))
@@ -2041,7 +2037,7 @@ (define-public hdf-eos5
(list autoconf automake gfortran libtool))
(build-system gnu-build-system)
(inputs
- (list hdf5-1.14 zlib gctp))
+ (list hdf5 zlib gctp))
(arguments
(list
#:configure-flags ''("--enable-install-include" "--enable-shared"
@@ -2076,13 +2072,13 @@ (define-public hdf-eos5
(license (license:non-copyleft home-page))))
(define-public hdf5-parallel-openmpi
- (package/inherit hdf5-1.14 ;use the latest
+ (package/inherit hdf5
(name "hdf5-parallel-openmpi")
(inputs
`(("mpi" ,openmpi)
,@(package-inputs hdf5)))
(arguments
- (substitute-keyword-arguments (package-arguments hdf5-1.14)
+ (substitute-keyword-arguments (package-arguments hdf5)
((#:configure-flags flags)
#~(cons "--enable-parallel"
(delete "--enable-cxx"
@@ -10481,7 +10477,7 @@ (define-public scilab
curl
fftw
gettext-minimal
- hdf5-1.14
+ hdf5
libarchive
libx11
libxml2