diff mbox series

[bug#52527,3/4] gnu: Add ghc-microspec.

Message ID ecc2c07f3e9abe3bc14b0f623a0a4a25f811e5d6.1639609080.git.avityazev@posteo.org
State New
Headers show
Series gnu: Add ghc-tidal. | expand

Commit Message

Aleksandr Vityazev Dec. 15, 2021, 11:01 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-microspec): New variable.
---
 gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5e009862d6..a253962142 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3047,6 +3047,25 @@  (define-public ghc-hosc
 haskell @code{supercollider} bindings.")
     (license license:gpl3)))
 
+(define-public ghc-microspec
+  (package
+    (name "ghc-microspec")
+    (version "0.2.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "microspec" version))
+       (sha256
+        (base32 "0615gdbsk7i3w71adjp69zabw4mli965wffm2h846hp6pjj31xcb"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-quickcheck))
+    (home-page "https://hackage.haskell.org/package/microspec")
+    (synopsis "Tiny QuickCheck test library with minimal dependencies")
+    (description
+     "A tiny, property-based and unit testing library with minimal
+dependencies.")
+    (license license:bsd-3)))
+
 (define-public ghc-dbus
   (package
     (name "ghc-dbus")