diff mbox series

[bug#50582,2/4] gnu: Add julia-sass.

Message ID eca237a402eef4f1c053a937ea24138e366e33d3.1631624546.git.efraim@flashner.co.il
State Accepted
Headers show
Series Julia-documenter | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner Sept. 14, 2021, 1:12 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-sass): New variable.
---
 gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Simon Tournier Sept. 27, 2021, 5:03 p.m. UTC | #1
Hi Efraim,

On mar., 14 sept. 2021 at 21:19, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-sass): New variable.
> ---
>  gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
> index a80964c2b0..2f953a33b7 100644
> --- a/gnu/packages/julia-xyz.scm
> +++ b/gnu/packages/julia-xyz.scm
> @@ -3403,6 +3403,28 @@ (define-public julia-safetestsets
>  a loadable module.")
>        (license license:expat))))
>
> +(define-public julia-sass
> +  (package
> +    (name "julia-sass")
> +    (version "0.2.0")
> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/piever/Sass.jl")
> +               (commit (string-append "v" version))))
> +        (file-name (git-file-name name version))
> +        (sha256
> +         (base32 "0y7kkkj717h5cj659ssry89i5r64symr6pvhr6vv4qmaxrnjxj92"))))
> +    (build-system julia-build-system)
> +    (propagated-inputs
> +     `(("julia-libsass-jll" ,julia-libsass-jll)))
> +    (home-page "https://github.com/piever/Sass.jl")
> +    (synopsis "Compile scss and sass file to css in Julia")

Again, I would remove «in Julia>..

> +    (description "This library provides a simple Julian API to use
> the

I would write «This package provides…»

> +@code{libsass} library to compile scss and sass files to css.")
> +    (license license:expat)))

LGTM.

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a80964c2b0..2f953a33b7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3403,6 +3403,28 @@  (define-public julia-safetestsets
 a loadable module.")
       (license license:expat))))
 
+(define-public julia-sass
+  (package
+    (name "julia-sass")
+    (version "0.2.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/piever/Sass.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0y7kkkj717h5cj659ssry89i5r64symr6pvhr6vv4qmaxrnjxj92"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-libsass-jll" ,julia-libsass-jll)))
+    (home-page "https://github.com/piever/Sass.jl")
+    (synopsis "Compile scss and sass file to css in Julia")
+    (description "This library provides a simple Julian API to use the
+@code{libsass} library to compile scss and sass files to css.")
+    (license license:expat)))
+
 (define-public julia-scratch
   (package
     (name "julia-scratch")