diff mbox series

[bug#69035] gnu: httpie: Update to 3.2.2.

Message ID ec36146d3f9fcbd36799ab81bc2f349742e71b02.1707012538.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#69035] gnu: httpie: Update to 3.2.2. | expand

Commit Message

kiasoc5 Feb. 11, 2024, 4:35 a.m. UTC
* gnu/packages/python-web.scm (httpie): Update to 3.2.2.
[propagated-inputs]: Remove python-pysocks; add python-importlib-metadata, python-pip,
and python-setuptools.

Change-Id: If767947e836bdee6bf145fc5290113d79e99fe89
---
 gnu/packages/python-web.scm | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)


base-commit: f45d05133472a9da13eae20ba4a676c696682c90

Comments

John Kehayias Feb. 14, 2024, 9:24 p.m. UTC | #1
On Sat, Feb 10, 2024 at 11:35 PM, kiasoc5 wrote:

> * gnu/packages/python-web.scm (httpie): Update to 3.2.2.
> [propagated-inputs]: Remove python-pysocks; add python-importlib-metadata, python-pip,
> and python-setuptools.
>
> Change-Id: If767947e836bdee6bf145fc5290113d79e99fe89
> ---
>  gnu/packages/python-web.scm | 16 +++++++++-------
>  1 file changed, 9 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 0c0cc46e5f..2f2682bc78 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -1280,28 +1280,30 @@ (define-public python-httplib2
>  (define-public httpie
>    (package
>      (name "httpie")
> -    (version "3.2.1")
> +    (version "3.2.2")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "httpie" version))
>         (sha256
>          (base32
> -         "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
> +         "140w4mr0w7scpf4j5qm4h475vbwrgxzkdwyygwcmql1r1cgngywb"))))
>      (build-system python-build-system)
>      (arguments
>       ;; The tests attempt to access external web servers, so we cannot run them.
>       '(#:tests? #f))
>      (propagated-inputs
> -     (list python-colorama
> +     (list python-charset-normalizer
> +           python-colorama
> +           python-defusedxml
> +           python-importlib-metadata
> +           python-multidict
> +           python-pip
>             python-pygments
>             python-requests
>             python-requests-toolbelt
> -           python-pysocks
> -           python-charset-normalizer
> -           python-defusedxml
>             python-rich
> -           python-multidict))
> +           python-setuptools))
>      (home-page "https://httpie.io")
>      (synopsis "cURL-like tool for humans")
>      (description
>
> base-commit: f45d05133472a9da13eae20ba4a676c696682c90

Pushed as a1f0b15444e146e5bb5eddd86e86def7aac854bb thank you!
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c0cc46e5f..2f2682bc78 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1280,28 +1280,30 @@  (define-public python-httplib2
 (define-public httpie
   (package
     (name "httpie")
-    (version "3.2.1")
+    (version "3.2.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "httpie" version))
        (sha256
         (base32
-         "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
+         "140w4mr0w7scpf4j5qm4h475vbwrgxzkdwyygwcmql1r1cgngywb"))))
     (build-system python-build-system)
     (arguments
      ;; The tests attempt to access external web servers, so we cannot run them.
      '(#:tests? #f))
     (propagated-inputs
-     (list python-colorama
+     (list python-charset-normalizer
+           python-colorama
+           python-defusedxml
+           python-importlib-metadata
+           python-multidict
+           python-pip
            python-pygments
            python-requests
            python-requests-toolbelt
-           python-pysocks
-           python-charset-normalizer
-           python-defusedxml
            python-rich
-           python-multidict))
+           python-setuptools))
     (home-page "https://httpie.io")
     (synopsis "cURL-like tool for humans")
     (description