diff mbox series

[bug#72102] gnu: python-emoji: Update to 2.12.1.

Message ID ec0bb558dc40a1753740dafbab99a604b1dde18b.1720907340.git.sisiutl@egregore.fun
State New
Headers show
Series [bug#72102] gnu: python-emoji: Update to 2.12.1. | expand

Commit Message

Sisiutl July 13, 2024, 10:01 p.m. UTC
Change-Id: Id262ba7f05f5fa6205bc19709442e62c1856f8a9
---
 gnu/packages/python-xyz.scm | 19 ++++++-------------
 1 file changed, 6 insertions(+), 13 deletions(-)

Comments

jgart July 15, 2024, 10:44 p.m. UTC | #1
Hi,

Thank you for your contribution!

I applied your patch with commit message modifications and some
adjustments.

Please review them for your next contribution in order to learn the
commit message style, etc.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 983d8d73b6..ece0e5ded6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14100,26 +14100,19 @@  (define-public python-immutabledict
 (define-public python-emoji
   (package
     (name "python-emoji")
-    (version "1.6.1")
+    (version "2.12.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "emoji" version))
        (sha256
-        (base32 "0923mpixwq6hdpkgvi4r46alfvf608iq975rb8lnqpq29j71mmjk"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "python" "-m" "pytest")))))))
-    (native-inputs
-     (list python-pytest))
+        (base32 "1svk94pad8gcvjwd329zmfrw09wakwh6qjvnhf6sa6k92y44i82a"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest python-typing-extensions))
     (home-page "https://github.com/carpedm20/emoji/")
     (synopsis "Emoji terminal output for Python")
-    (description "This package provides Emoji terminal output for Python.  The
+    (description
+     "This package provides Emoji terminal output for Python.  The
 entire set of Emoji codes as defined by the Unicode Consortium is supported in
 addition to a bunch of aliases.")
     (license license:bsd-3)))