diff mbox series

[bug#56795,core-updates] gnu: texlive-xcolor: Fix merge.

Message ID eb97c43fdcc8a4f21ca2b91ccbdf2d3683a55d37.1658931473.git.code@greghogan.com
State Accepted
Headers show
Series [bug#56795,core-updates] gnu: texlive-xcolor: Fix merge. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan July 27, 2022, 2:18 p.m. UTC
* gnu/packages/tex.scm (texlive-xcolor)[arguments]<#:phases>: Restore
code from commit 5e796bfc22076a1126beaa853d9cac16f5c9a23d which was
reverted by the merge commit 8c3e9da13a3c92a7db308db8c0d81cb474ad7799.
---
 gnu/packages/tex.scm | 23 +++++++++++++++--------
 1 file changed, 15 insertions(+), 8 deletions(-)

Comments

Marius Bakke Sept. 1, 2022, 8:57 p.m. UTC | #1
Greg Hogan <code@greghogan.com> skriver:

> * gnu/packages/tex.scm (texlive-xcolor)[arguments]<#:phases>: Restore
> code from commit 5e796bfc22076a1126beaa853d9cac16f5c9a23d which was
> reverted by the merge commit 8c3e9da13a3c92a7db308db8c0d81cb474ad7799.

Nice catch!  Unfortunately I did not see this patch before going on the
same debugging journey and arriving at the exact same solution in
121f6e0b0c45dba24301fbd405d07123e82c2de6.

Sorry for the duplicate work.  :-(

By the way, you have been around for a while now and generally produce
high quality patches.  Consider applying for commit access.  :-)

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ad16a1b46..482f18505c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3391,14 +3391,21 @@  (define-public texlive-xcolor
           #~(modify-phases #$phases
               (add-after 'unpack 'chdir
                 (lambda _ (chdir "source/latex/xcolor") #t))
-              (add-after 'install 'move-files
-                (lambda* (#:key outputs #:allow-other-keys)
-                  (let ((share (string-append (assoc-ref outputs "out")
-                                              "/share/texmf-dist")))
-                    (mkdir-p (string-append share "/dvips/xcolor"))
-                    (rename-file (string-append share "/tex/latex/xcolor/xcolor.pro")
-                                 (string-append share "/dvips/xcolor/xcolor.pro"))
-                    #t)))))))
+              (replace 'copy-files
+                (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc)
+                    (let ((share (string-append #$output
+                                                "/share/texmf-dist")))
+                      (mkdir-p (string-append share "/dvips/xcolor"))
+                      (rename-file
+                       (string-append share "/tex/latex/xcolor/xcolor.pro")
+                       (string-append share "/dvips/xcolor/xcolor.pro"))))))))))
       ;; TODO: Propagate texlive-hyperref and many others in the next rebuild
       ;; cycle.  Grep for '\usepackage' to see what packages it requires.
       ;; (propagated-inputs (list texlive-hyperref ...))