diff mbox series

[bug#54757] gnu: Add librseq.

Message ID eb897ca2f879013bc5d792e8eaa792e68ac1789f.1649287765.git.olivier.dion@polymtl.ca
State Accepted
Headers show
Series [bug#54757] gnu: Add librseq. | expand

Commit Message

Olivier Dion April 6, 2022, 11:30 p.m. UTC
* gnu/packages/engineering.scm (librseq): New variable.
---
 gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Liliana Marie Prikler April 7, 2022, 6:06 a.m. UTC | #1
Am Mittwoch, dem 06.04.2022 um 19:30 -0400 schrieb Olivier Dion:
> * gnu/packages/engineering.scm (librseq): New variable.
> ---
>  gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/engineering.scm
> b/gnu/packages/engineering.scm
> index cb721ddd2e..9b0a917f8e 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -1148,6 +1148,31 @@ (define-public kicad-templates
>      (description "This package contains the official KiCad project
> and
>  worksheet templates.")))
>  
> +(define-public librseq
> +  (let ((commit "170f840b498e1aff068b90188727a656111bfc2f")
> +        (hash
> "0rdx59y8y9x8cfmmx5gl66gibkzpk3kw5lrrqhrxan8zr37a055y"))
Missing revision.  Also specify why a non-release commit is used.
> +    (package
> +      (name "librseq")
> +      (version "0.0.0")
Use git-version.
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/compudj/librseq.git")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256 (base32 hash))))
Type out hash.
> +      (build-system gnu-build-system)
> +      (native-inputs (list autoconf automake libtool))
> +      (propagated-inputs (list linux-libre-headers))
> +      (home-page "https://github.com/compudj/librseq")
> +      (synopsis "Userspace library for restartable sequences")
> +      (description "A restartable sequence is a critical region
> delimited by a
> +program where if the execution its preempted or interrupted, the
> kernel will
> +divert the program control flow to a custom handler.  They are a
> good
> +alternative to atomic operations for critical fast paths and are
> usually used
> +in the context of per-cpu data.")
> +      (license (list license:lgpl2.1 license:expat)))))
> +
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index cb721ddd2e..9b0a917f8e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1148,6 +1148,31 @@  (define-public kicad-templates
     (description "This package contains the official KiCad project and
 worksheet templates.")))
 
+(define-public librseq
+  (let ((commit "170f840b498e1aff068b90188727a656111bfc2f")
+        (hash "0rdx59y8y9x8cfmmx5gl66gibkzpk3kw5lrrqhrxan8zr37a055y"))
+    (package
+      (name "librseq")
+      (version "0.0.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/compudj/librseq.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256 (base32 hash))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf automake libtool))
+      (propagated-inputs (list linux-libre-headers))
+      (home-page "https://github.com/compudj/librseq")
+      (synopsis "Userspace library for restartable sequences")
+      (description "A restartable sequence is a critical region delimited by a
+program where if the execution its preempted or interrupted, the kernel will
+divert the program control flow to a custom handler.  They are a good
+alternative to atomic operations for critical fast paths and are usually used
+in the context of per-cpu data.")
+      (license (list license:lgpl2.1 license:expat)))))
+
 (define-public linsmith
   (package
     (name "linsmith")