@@ -227,7 +227,7 @@ (define-public khal
(define-public remind
(package
(name "remind")
- (version "3.3.7")
+ (version "5.0.5")
(source
(origin
(method url-fetch)
@@ -238,7 +238,9 @@ (define-public remind
".")
".tar.gz"))
(sha256
- (base32 "0gca7f5gc0zr111c28hxw4hycz1hr9z7s912bpzm92g1s4llxjc7"))))
+ (base32 "0yc0lfrl0zzc1bn5fkigararg44bdryis7vjnm8vzs21as9r0dbz"))))
+ (properties
+ `((output-synopsis "tcl" "graphical front-end to Remind calendar program")))
(build-system gnu-build-system)
(outputs (list "out"
"tcl")) ; more than doubles the closure by >110 MiB
@@ -255,24 +257,24 @@ (define-public remind
(let ((from (string-append out "/" file))
(to (string-append tcl "/" file)))
(mkdir-p (dirname to))
- (rename-file from to)
- ;; For simplicity, wrap all scripts with the same variables
- ;; even though, e.g., inetutils is not needed by cm2rem.tcl.
- ;; XXX Using WRAP-SCRIPT currently breaks tkremind.
- (wrap-program to
- `("PATH" ":" prefix
- ,(map (lambda (dir)
- (string-append dir "/bin"))
- (append (list out tcl)
- (map (lambda (input)
- (assoc-ref inputs input))
- (list "tcl" "tk" "inetutils")))))
- `("TCLLIBPATH" " " =
- (,(getenv "TCLLIBPATH"))))))
- (list "bin/cm2rem.tcl"
- "bin/tkremind"))))))))
+ (rename-file from to)))
+ (list "bin/tkremind"
+ "share/man/man1/tkremind.1"
+ "share/pixmaps/tkremind.png"
+ "share/applications/tkremind.desktop"))
+ (wrap-program (string-append tcl "/bin/tkremind")
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (append (list out tcl)
+ (map (lambda (input)
+ (assoc-ref inputs input))
+ (list "tcl" "tk" "inetutils")))))
+ `("TCLLIBPATH" " " =
+ (,(getenv "TCLLIBPATH"))))))))))
(inputs
(list bash-minimal inetutils tcl tcllib tk))
+ (native-inputs (list tzdata)) ; required for some tests
(home-page "https://dianne.skoll.ca/projects/remind/")
(synopsis "Sophisticated calendar and alarm program")
(description
From: Luís Henriques <henrix@camandro.org> * gnu/packages/calendar.scm (remind): Update to 05.00.05. [properties]: Add tcl output synopsis. [arguments]<#:phases>: Update list of files to include in tcl output. There's only one tcltk script now. [native-inputs]: Add tzdata. Change-Id: I729d48a8e538039ef5d8c9cb8bd232b3946b5f76 --- gnu/packages/calendar.scm | 38 ++++++++++++++++++++------------------ 1 file changed, 20 insertions(+), 18 deletions(-) base-commit: 993d6d2e7be4dac738629c76a51058f4dc5bc449 prerequisite-patch-id: 756e7e982cd0fa0a1490e95e7bb6abdada32b75a