diff mbox series

[bug#70133] gnu: gpaste: Update to v44.1.

Message ID eb1468a2b58c54161d85bcf56b37ac1897333450.1712005405.git.attila@lendvai.name
State New
Headers show
Series [bug#70133] gnu: gpaste: Update to v44.1. | expand

Commit Message

Attila Lendvai April 1, 2024, 9:03 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

Change-Id: I2395c637caf151739740edca82fbb397e82d0fcf

* gnu/packages/gnome-xyz.scm (gpaste): Delete libarchive dependency (it seems
to be not needed anymore), add dependency to desktop-file-utils (for
update-desktop-database), and change gtk to gtk+ (which includes gdk).

Change-Id: I9e9ff51398bb49f2c81adbeac8817638ad62efa2
---
 gnu/packages/gnome-xyz.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 6e2db85ca83528199a46b002d2592bd4bef017c8

Comments

Liliana Marie Prikler April 2, 2024, 4:56 p.m. UTC | #1
Am Montag, dem 01.04.2024 um 23:03 +0200 schrieb
attila.lendvai@gmail.com:
> From: Attila Lendvai <attila@lendvai.name>
> 
> Change-Id: I2395c637caf151739740edca82fbb397e82d0fcf
> 
> * gnu/packages/gnome-xyz.scm (gpaste): Delete libarchive dependency
> (it seems
> to be not needed anymore), add dependency to desktop-file-utils (for
> update-desktop-database), and change gtk to gtk+ (which includes
> gdk).
Make sure to follow our conventions for the ChangeLog.  In particular,
the "v" in the title is unnecessary; repeat the update for the
ChangeLog, and add a dedicated [inputs] "subsection" detailing the
changes (i.e. "Add desktop-file-utils.  Remove libarchive.  Replace…")

> 
> Change-Id: I9e9ff51398bb49f2c81adbeac8817638ad62efa2
> ---
>  gnu/packages/gnome-xyz.scm | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index d81cf034a15..e8f70f477e5 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -1011,7 +1011,7 @@ (define-public gnome-shell-extension-night-
> theme-switcher
>  (define-public gpaste
>    (package
>      (name "gpaste")
> -    (version "42.2")
> +    (version "44.1")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -1020,12 +1020,12 @@ (define-public gpaste
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -               
> "0qq2p19p3r3lz8yfynpnf36cipv54bzdbmq1x5zgwhyl4yl41g28"))
> +               
> "1amfr8hwf7401xa3fzaa8w17w3v3lxx0fkr7rqkkyfy57iavrykk"))
>                (patches
>                 (search-patches "gpaste-fix-paths.patch"))))
>      (build-system meson-build-system)
>      (native-inputs
> -     (list gcr-3
> +     (list gcr
>             gettext-minimal
>             gobject-introspection
>             (list glib "bin")            ; for glib-compile-resources
> @@ -1033,11 +1033,11 @@ (define-public gpaste
>             vala))
>      (inputs
>       (list appstream-glib
> +           desktop-file-utils           ; for update-desktop-
> database
>             gjs
> -           gtk
> +           gtk+
>             mutter
> -           libadwaita
> -           libarchive))
> +           libadwaita))
>      (arguments
>       (list #:glib-or-gtk? #true
>             #:configure-flags
Content-wise LGTM.

Cheers
Leo Famulari April 2, 2024, 7:05 p.m. UTC | #2
On Tue, Apr 02, 2024 at 06:56:26PM +0200, Liliana Marie Prikler wrote:
> Make sure to follow our conventions for the ChangeLog.  In particular,
> the "v" in the title is unnecessary; repeat the update for the
> ChangeLog, and add a dedicated [inputs] "subsection" detailing the
> changes (i.e. "Add desktop-file-utils.  Remove libarchive.  Replace…")

Thanks, I adjusted the changelog accordingly and pushed as
4d994f98a49e1a6e58b9b0b512a05efc1c431a50
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d81cf034a15..e8f70f477e5 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1011,7 +1011,7 @@  (define-public gnome-shell-extension-night-theme-switcher
 (define-public gpaste
   (package
     (name "gpaste")
-    (version "42.2")
+    (version "44.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1020,12 +1020,12 @@  (define-public gpaste
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0qq2p19p3r3lz8yfynpnf36cipv54bzdbmq1x5zgwhyl4yl41g28"))
+                "1amfr8hwf7401xa3fzaa8w17w3v3lxx0fkr7rqkkyfy57iavrykk"))
               (patches
                (search-patches "gpaste-fix-paths.patch"))))
     (build-system meson-build-system)
     (native-inputs
-     (list gcr-3
+     (list gcr
            gettext-minimal
            gobject-introspection
            (list glib "bin")            ; for glib-compile-resources
@@ -1033,11 +1033,11 @@  (define-public gpaste
            vala))
     (inputs
      (list appstream-glib
+           desktop-file-utils           ; for update-desktop-database
            gjs
-           gtk
+           gtk+
            mutter
-           libadwaita
-           libarchive))
+           libadwaita))
     (arguments
      (list #:glib-or-gtk? #true
            #:configure-flags