diff mbox series

[bug#72623] gnu: ccl: Update to 1.13

Message ID ead4ac5184b5d66e92f774c1871ff2c531f40fe6.1723650274.git.ashish.is@lostca.se
State New
Headers show
Series [bug#72623] gnu: ccl: Update to 1.13 | expand

Commit Message

guix-patches--- via Aug. 14, 2024, 3:44 p.m. UTC
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/lisp.scm (ccl): Update to 1.13.
[inputs] Update ccl bootstrap souirces.

Change-Id: Id2b9d29b4ea51aba23ca1aee770e33755b062b19
---
 gnu/packages/lisp.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: aadc73c8d1a622f76ee02aca22eb89c83023680f

Comments

Guillaume Le Vaillant Aug. 15, 2024, 12:26 p.m. UTC | #1
Patch applied as c9dd09855e69af3e166ddfdafb3a1f57a26901e0.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 97f7dd357b..d78ca5ddb5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -230,7 +230,7 @@  (define-public ccl
     (name "ccl")
     ;; XXX When updating this package, check whether we can simply append
     ;; VERSION to the ccl-bootstrap URL again, instead of per architecture.
-    (version "1.12.1")
+    (version "1.13")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -239,7 +239,7 @@  (define-public ccl
               (file-name (git-file-name "ccl" version))
               (sha256
                (base32
-                "1zz291lvsrr7pps8wfl2kdxsnzjngqi4v3mil14pga4r5zanmsi7"))))
+                "12cb3gp43bhl7nyms3a4lix8j1s3arnp124d3ahc2lhlrjirs0mr"))))
     (build-system gnu-build-system)
     ;; CCL consists of a "lisp kernel" and "heap image", both of which are
     ;; shipped in precompiled form in source tarballs.  The former is a C
@@ -253,18 +253,18 @@  (define-public ccl
            (uri (string-append
                  "https://github.com/Clozure/ccl/releases/download/v"
                  (match (%current-system)
-                   ("armhf-linux" "1.12/linuxarm")
+                   ("armhf-linux" "1.13/linuxarm")
                    ;; XXX: This source only works on x86, but provide it as a
                    ;; catch-all to prevent errors when querying this package
                    ;; on unsupported platforms.
-                   (_ "1.12.1/linuxx86"))
+                   (_ "1.13/linuxx86"))
                  ".tar.gz"))
            (sha256
             (base32
              (match (%current-system)
                ("armhf-linux"
-                "0x4bjx6cxsjvxyagijhlvmc7jkyxifdvz5q5zvz37028va65243c")
-               (_ "0ll017ajcfsyx8f7zsy4394y8xxvz40iz0gcsmznp0n3mf0xi67c"))))))))
+                "0isihnk275yqz6wn34ab38g7lf1nq0sqc00h0g22fvw77d60q9cb")
+               (_ "04ry8zwrcjjmzbxp43nkknchabk6i6mclrzg5biwfp1h64bcnzfx"))))))))
     (native-inputs
      (list cl-asdf m4))
     (arguments