diff mbox series

[bug#70220,go-team,1/2] gnu: Add go-github-com-openprinting-goipp.

Message ID eabcb576e8c81014bdd449719a92734edb9a8dbc.1712345544.git.herman@rimm.ee
State New
Headers show
Series Add ipp-usb package. | expand

Commit Message

Herman Rimm April 5, 2024, 7:35 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-openprinting-goipp): Add
variable.
---
 gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f4ec142949..ab55517eec 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1007,6 +1007,28 @@  (define-public go-github-com-op-go-logging
 levels per backend and logger.")
     (license license:bsd-3)))
 
+(define-public go-github-com-openprinting-goipp
+  (package
+    (name "go-github-com-openprinting-goipp")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OpenPrinting/goipp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1p05dk37l393byvjanvi3ipqcax320vf3qynlzazm7czzzlw448h"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/OpenPrinting/goipp"))
+    (home-page "https://github.com/OpenPrinting/goipp")
+    (synopsis "IPP core protocol implementation")
+    (description
+      "The goipp package implements the IPP core protocol, as defined by
+@@url{https://rfc-editor.org/rfc/rfc8010.html,RFC 8010}.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-orisano-pixelmatch
   (package
     (name "go-github-com-orisano-pixelmatch")