[bug#77561] gnu: emacs-org-roam: Update to 2.2.2-2.046822b.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-org-roam): Update to 2.2.2-2.046822b.
Change-Id: I91d74b8b5c20d60084849ee0496cc8f1e262ff79
---
gnu/packages/emacs-xyz.scm | 45 +++++++++++++++-----------------------
1 file changed, 18 insertions(+), 27 deletions(-)
base-commit: bcfb283cda1b782129c8a70b69d216b925501185
Comments
Hi Cayetano,
On Sun, 06 Apr 2025 03:24:44 +0800,
Cayetano Santos wrote:
>
> * gnu/packages/emacs-xyz.scm (emacs-org-roam): Update to 2.2.2-2.046822b.
>
> Change-Id: I91d74b8b5c20d60084849ee0496cc8f1e262ff79
> ---
> gnu/packages/emacs-xyz.scm | 45 +++++++++++++++-----------------------
> 1 file changed, 18 insertions(+), 27 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9bcf26a021..785266ee08 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -40138,8 +40138,8 @@ (define-public emacs-orca
> (license license:gpl3+))))
>
> (define-public emacs-org-roam
> - (let ((commit "0b9fcbc97b65b349826e63bad89ca121a08fd2be")
> - (revision "1"))
> + (let ((commit "046822b512ffecdee7d110f73dd3a511802ca590")
> + (revision "2"))
> (package
> (name "emacs-org-roam")
> (version (git-version "2.2.2" revision commit))
> @@ -40151,15 +40151,23 @@ (define-public emacs-org-roam
> (commit commit)))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "04vqwrsb71jdb66fkahmxwvx8cssgqamrradbdgp3ygf8alwc7ml"))))
> + (base32 "0jbj48glh0r6fkb0lk1xb9067x2myp3krkw2byycijwdq1nlqzv2"))))
> (build-system emacs-build-system)
> (arguments
> (list
> #:phases
> #~(modify-phases %standard-phases
> + (add-after 'unpack 'make-info
> + (lambda _
> + (invoke "make" "-C" "doc" "info")
> + (copy-file "doc/org-roam.info" "org-roam.info")))
> + (add-after 'make-info 'install-image
> + (lambda* (#:key outputs #:allow-other-keys)
> + (install-file "doc/images/org-ref-citelink.png"
> + (string-append #$output "/share/info/images"))))
> ;; Move the extensions source files to the top level, which
> ;; is included in the EMACSLOADPATH.
> - (add-after 'unpack 'move-source-files
> + (add-after 'install-image 'move-source-files
> (lambda _
> (let ((el-files (find-files "./extensions" ".*\\.el$")))
> (for-each (lambda (f)
> @@ -40170,31 +40178,14 @@ (define-public emacs-org-roam
> (make-file-writable "org-roam-graph.el")
> (emacs-substitute-variables "org-roam-graph.el"
> ("org-roam-graph-executable"
> - (search-input-file inputs "/bin/dot")))))
> - (add-after 'install 'install-image
> - (lambda* (#:key outputs #:allow-other-keys)
> - (install-file "doc/images/org-ref-citelink.png"
> - (string-append #$output "/share/info/images"))))
> - (add-after 'install-image 'make-info
> - (lambda* (#:key outputs #:allow-other-keys)
> - (with-directory-excursion "doc"
> - (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
> - (install-file "org-roam.info"
> - (string-append #$output "/share/info"))))))))
Please reflect the change in commit message.
> - (inputs
> - (list graphviz))
> - (native-inputs
> - (list texinfo))
> - (propagated-inputs
> - (list emacs-dash
> - emacs-emacsql
> - emacs-f
> - emacs-magit
> - emacs-org
> - emacs-s))
> + (search-input-file inputs "/bin/dot"))))))))
> + (inputs (list graphviz))
> + (native-inputs (list texinfo))
> + (propagated-inputs (list emacs-dash emacs-emacsql emacs-magit))
The diff doesn't look good, please make a minimal change and reflect the inputs
change in commit message.
> (home-page "https://github.com/org-roam/org-roam/")
> (synopsis "Non-hierarchical note-taking with Org mode")
> - (description "Emacs Org Roam is a solution for taking non-hierarchical
> + (description
> + "Emacs Org Roam is a solution for taking non-hierarchical
This change doesn't seem relevant?
> notes with Org mode. Notes are captured without hierarchy and are connected
> by tags. Notes can be found and created quickly. Org Roam should also work
> as a plug-and-play solution for anyone already using Org mode for their
>
> base-commit: bcfb283cda1b782129c8a70b69d216b925501185
> --
> 2.49.0
Please send a revised patch addressing above issues.
Thanks
@@ -40138,8 +40138,8 @@ (define-public emacs-orca
(license license:gpl3+))))
(define-public emacs-org-roam
- (let ((commit "0b9fcbc97b65b349826e63bad89ca121a08fd2be")
- (revision "1"))
+ (let ((commit "046822b512ffecdee7d110f73dd3a511802ca590")
+ (revision "2"))
(package
(name "emacs-org-roam")
(version (git-version "2.2.2" revision commit))
@@ -40151,15 +40151,23 @@ (define-public emacs-org-roam
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "04vqwrsb71jdb66fkahmxwvx8cssgqamrradbdgp3ygf8alwc7ml"))))
+ (base32 "0jbj48glh0r6fkb0lk1xb9067x2myp3krkw2byycijwdq1nlqzv2"))))
(build-system emacs-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'make-info
+ (lambda _
+ (invoke "make" "-C" "doc" "info")
+ (copy-file "doc/org-roam.info" "org-roam.info")))
+ (add-after 'make-info 'install-image
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "doc/images/org-ref-citelink.png"
+ (string-append #$output "/share/info/images"))))
;; Move the extensions source files to the top level, which
;; is included in the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
+ (add-after 'install-image 'move-source-files
(lambda _
(let ((el-files (find-files "./extensions" ".*\\.el$")))
(for-each (lambda (f)
@@ -40170,31 +40178,14 @@ (define-public emacs-org-roam
(make-file-writable "org-roam-graph.el")
(emacs-substitute-variables "org-roam-graph.el"
("org-roam-graph-executable"
- (search-input-file inputs "/bin/dot")))))
- (add-after 'install 'install-image
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "doc/images/org-ref-citelink.png"
- (string-append #$output "/share/info/images"))))
- (add-after 'install-image 'make-info
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion "doc"
- (invoke "makeinfo" "-o" "org-roam.info" "org-roam.texi")
- (install-file "org-roam.info"
- (string-append #$output "/share/info"))))))))
- (inputs
- (list graphviz))
- (native-inputs
- (list texinfo))
- (propagated-inputs
- (list emacs-dash
- emacs-emacsql
- emacs-f
- emacs-magit
- emacs-org
- emacs-s))
+ (search-input-file inputs "/bin/dot"))))))))
+ (inputs (list graphviz))
+ (native-inputs (list texinfo))
+ (propagated-inputs (list emacs-dash emacs-emacsql emacs-magit))
(home-page "https://github.com/org-roam/org-roam/")
(synopsis "Non-hierarchical note-taking with Org mode")
- (description "Emacs Org Roam is a solution for taking non-hierarchical
+ (description
+ "Emacs Org Roam is a solution for taking non-hierarchical
notes with Org mode. Notes are captured without hierarchy and are connected
by tags. Notes can be found and created quickly. Org Roam should also work
as a plug-and-play solution for anyone already using Org mode for their