diff mbox series

[bug#72729] gnu: protobuf-c: Fix cross-compilation.

Message ID ea55063f975b27f84ff8fb19028629eb463d937c.1724144883.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#72729] gnu: protobuf-c: Fix cross-compilation. | expand

Commit Message

Z572 Aug. 20, 2024, 9:08 a.m. UTC
* gnu/packages/protobuf.scm (protobuf-c): Fix cross-compilation.
[native-inputs]: When cross-compilation, add protobuf.
[arguments]<#:configure-flags>: When cross-compilation, Set PROTOC variable.

Change-Id: Idd660f526b7c90277cb4399997cdb7ce72e4f1c5
---
 gnu/packages/protobuf.scm | 14 ++++++++++++--
 1 file changed, 12 insertions(+), 2 deletions(-)


base-commit: 7f14eda95f5f5694cb62decb1bcff46685b9c287

Comments

Z572 Aug. 23, 2024, 2:44 p.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/protobuf.scm (protobuf-c): Fix cross-compilation.
> [native-inputs]: When cross-compilation, add protobuf.
> [arguments]<#:configure-flags>: When cross-compilation, Set PROTOC variable.
>
> Change-Id: Idd660f526b7c90277cb4399997cdb7ce72e4f1c5
> ---
>  gnu/packages/protobuf.scm | 14 ++++++++++++--
>  1 file changed, 12 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
> index d47b67fa61..b8679eff25 100644
> --- a/gnu/packages/protobuf.scm
> +++ b/gnu/packages/protobuf.scm
> @@ -8,7 +8,7 @@
>  ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
>  ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
> -;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
> +;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -262,7 +262,17 @@ (define-public protobuf-c
>                  "17rk42r3gcc46c2svd1mxs542wnl4mi77a6klkhg6wl1a36zmi2c"))))
>      (build-system gnu-build-system)
>      (inputs (list protobuf))
> -    (native-inputs (list pkg-config))
> +    (native-inputs (append (if (%current-target-system)
> +                               (list protobuf)
> +                               '())
> +                           (list pkg-config)))
> +    (arguments (if (%current-target-system)
> +                   (list #:configure-flags
> +                         #~(list
> +                            (string-append
> +                             "PROTOC="
> +                             (search-input-file %build-inputs "bin/protoc"))))
> +                   (list)))
>      (home-page "https://github.com/protobuf-c/protobuf-c")
>      (synopsis "Protocol Buffers implementation in C")
>      (description
>
> base-commit: 7f14eda95f5f5694cb62decb1bcff46685b9c287

push, close.
diff mbox series

Patch

diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index d47b67fa61..b8679eff25 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -262,7 +262,17 @@  (define-public protobuf-c
                 "17rk42r3gcc46c2svd1mxs542wnl4mi77a6klkhg6wl1a36zmi2c"))))
     (build-system gnu-build-system)
     (inputs (list protobuf))
-    (native-inputs (list pkg-config))
+    (native-inputs (append (if (%current-target-system)
+                               (list protobuf)
+                               '())
+                           (list pkg-config)))
+    (arguments (if (%current-target-system)
+                   (list #:configure-flags
+                         #~(list
+                            (string-append
+                             "PROTOC="
+                             (search-input-file %build-inputs "bin/protoc"))))
+                   (list)))
     (home-page "https://github.com/protobuf-c/protobuf-c")
     (synopsis "Protocol Buffers implementation in C")
     (description