diff mbox series

[bug#69960,gnome-team,2/2] gnu: todoman: Fix tests.

Message ID ea51946638b9941b04cef8f0ee7763e0bf5ff1a9.1711189473.git.vivien@planete-kraus.eu
State New
Headers show
Series Fix todoman test failure | expand

Commit Message

Vivien Kraus March 23, 2024, 10:21 a.m. UTC
* gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load the `ci'
hypothesis profile provided by upstream.

Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
---
 gnu/packages/task-management.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler March 23, 2024, 10:50 a.m. UTC | #1
Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
> * gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load
> the `ci'
> hypothesis profile provided by upstream.
> 
> Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
SGTM.  If you're okay with it, I'd locally rephrase this to [#:phases]
<check> and push it with that change once it's confirmed by the rest,
WDTY?
Vivien Kraus March 23, 2024, 10:52 a.m. UTC | #2
Le samedi 23 mars 2024 à 11:50 +0100, Liliana Marie Prikler a écrit :
> Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
> > * gnu/packages/task-management.scm (todoman) [#:phase 'check]: Load
> > the `ci'
> > hypothesis profile provided by upstream.
> > 
> > Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
> SGTM.  If you're okay with it, I'd locally rephrase this to
> [#:phases]
> <check> and push it with that change once it's confirmed by the rest,
> WDTY?

Sorry, I always hesitate with this. I will try my best to do the
correct thing in the future, but in the mean time, please go ahead.

Vivien
Liliana Marie Prikler March 24, 2024, 11:15 a.m. UTC | #3
Am Samstag, dem 23.03.2024 um 11:52 +0100 schrieb Vivien Kraus:
> Le samedi 23 mars 2024 à 11:50 +0100, Liliana Marie Prikler a écrit :
> > Am Samstag, dem 23.03.2024 um 11:21 +0100 schrieb Vivien Kraus:
> > > * gnu/packages/task-management.scm (todoman) [#:phase 'check]:
> > > Load the `ci' hypothesis profile provided by upstream.
> > > 
> > > Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204
> > SGTM.  If you're okay with it, I'd locally rephrase this to
> > [#:phases] <check> and push it with that change once it's confirmed
> > by the rest,WDTY?
> 
> Sorry, I always hesitate with this. I will try my best to do the
> correct thing in the future, but in the mean time, please go ahead.
It's fine – I do fall back to my own writing style a lot, and the
guidelines aren't super close on the details as of yet, so I sometimes
go ahead with edits and hesitate at other times.

Anyway, pushed.
diff mbox series

Patch

diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index aac643799f..96df50d747 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -453,7 +453,8 @@  (define-public todoman
           (replace 'check
             (lambda* (#:key inputs outputs tests? #:allow-other-keys)
               (when tests?
-                (invoke "pytest" "-vv" "tests" "-k"
+                (invoke "pytest" "--hypothesis-profile=ci"
+                        "-vv" "tests" "-k"
                         (string-append
                          ;; Test expects wrong output string.
                          "not test_bad_start_date "